1. Windows Central Question's Avatar
    got the blu wind hd w510u cell type 01 plug it in and it starts up just fine for a sec or two then goes black with a pic of a battery with a question mark or a lighting bolt next to a setting symbol. what does it mean? And CAN IT BE FIXED?
    08-01-2016 08:20 PM
  2. realwarder's Avatar
    I don't know IF IT CAN BE FIXED. But why don't you try the WDRT tool and try and see if that will recover the phone

    https://support.microsoft.com/en-us/...overy-tool-faq
    08-01-2016 11:24 PM
  3. Chintan Gohel's Avatar
    got the blu wind hd w510u cell type 01 plug it in and it starts up just fine for a sec or two then goes black with a pic of a battery with a question mark or a lighting bolt next to a setting symbol. what does it mean? And CAN IT BE FIXED?
    can you leave it on charger for a couple of hours?

    If you need additional help or have more questions or details to share, please join the site so you can reply in this thread. See this link for instructions on how to join Windows Central.
    08-02-2016 12:46 AM

Similar Threads

  1. WTB mozo black leather backing for 950 XL
    By beman39 in forum Marketplace Archive
    Replies: 12
    Last Post: 09-26-2016, 09:28 PM
  2. Replies: 1
    Last Post: 08-01-2016, 11:52 PM
  3. Replies: 1
    Last Post: 08-01-2016, 11:34 PM
  4. Microsoft and PicsArt team up to offer a superhero clipart package for charity
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 08-01-2016, 03:00 PM
LINK TO POST COPIED TO CLIPBOARD