1. Andrew Brehm's Avatar
    My Surface Pro X often disappears from the network.

    I have every settings in the power plan tell it to stay up and running when connected to a power source.

    But it still turns itself offline.

    The first event in eventviewer when I wake it up is "The system is exiting connected standby", which makes me believe that it, against orders, entered something called "connected standby".

    How can I turn off this "feature"?

    Any ideas?
    12-09-2021 05:43 AM
  2. interlocutor1980's Avatar
    Hoping that this link will help you out...
    https://support.microsoft.com/en-us/...ion=Windows_10
    12-09-2021 11:24 AM
  3. Andrew Brehm's Avatar
    Hoping that this link will help you out...
    https://support.microsoft.com/en-us/...ion=Windows_10
    I am not sure I understand. Is this a Wi-Fi setting I am missing?

    To me it seems like the device is turned off (or sleeping). Wi-Fi is working as soon as I wake it up.
    12-10-2021 03:21 AM
  4. HelloNNNewman's Avatar
    I am not sure I understand. Is this a Wi-Fi setting I am missing?

    To me it seems like the device is turned off (or sleeping). Wi-Fi is working as soon as I wake it up.
    Ignore that link - it has nothing to do with your question.

    Connected Standby was Microsoft's attempt (starting back with Win 8) to give their OS that 'always on' service that people were seeing on iPads, other tablets, and cell phones. As time went on they rolled it out to other chipsets as they expanded. It isn't designed to be easily turned off because they wanted it to basically replace older power management states. But because a lot of users complain about experiencing issues when it is used, many will disable it using the Registry settings. This isn't for everyone and messing with the Registry can completely bork your computer if it is done incorrectly. So if you do it - make sure you back up the Registry and create a Restore Point beforehand.

    1. Open the registry editor (windows key and type “regedit”)
    2. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\CsEnabled
    If you have Connected Standby enabled, this variable will have a 1 (one) in it. To disable it, double-click on the CsEnabled variable and put a 0 (zero) in there.
    3. Reboot and you are done.

    There is a caveat to all of this, once you disable Connected Standby, your PC won’t be able to sleep anymore. Hibernate should still work though.

    Hopefully this helps your issue!
    Andrew Brehm likes this.
    12-10-2021 08:33 AM
  5. Andrew Brehm's Avatar

    Hopefully this helps your issue!
    I think it did. Thank you.
    HelloNNNewman likes this.
    12-10-2021 09:00 AM

Similar Threads

  1. Final Fantasy 14 (FFXIV): Endwalker is having server problems
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 12-08-2021, 09:20 PM
  2. A new Fallout 76 update is releasing with new content, rewards, and more
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 12-08-2021, 05:42 PM
  3. How to watch The Game Awards 2021
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 12-08-2021, 05:11 PM
  4. Grab the SteelSeries Rival 3 wireless mouse down to its lowest price at $25
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 12-08-2021, 04:11 PM
  5. This is the best RAM to accompany your Intel Core i7-12700K
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 12-08-2021, 03:11 PM
LINK TO POST COPIED TO CLIPBOARD