The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
04-11-2009 01:47 PM
127 ... 3456
tools
  1. jakubd's Avatar
    Just a quick info: updated firmware, updated the driver from build 64 (BTW: http://celiocorp.com/install/beta/ -> TouchPro points to http://celiocorp.com/install/eula.as...6_01040093.CAB and should point to http://celiocorp.com/install/eula.as...6_01040093.CAB) and... it doesn't work correctly (Stock HTC TouchPro ROM, but did not try HR yet). Devices connect, TouchFlo turns off, R shows on touchpro screen and... that's all folks: all I can do is soft reset (left it for 5 minutes and nothing more happens).
    Will report more as I plan to change ROM so will be able to HR and test it again.

    Update: HR solved the problem, I'm testing now PROven ROM v2.2 from qsqa and it seems to work quite ok (Opera 9.5 works quite OK!): anyway I have experienced some disconnections (even though I used USB) and after that I had to correct font size and turn on TouchFlo3D - as usual.
    Last edited by jakubd; 02-15-2009 at 12:36 PM.
    02-13-2009 05:50 PM
  2. mknollman's Avatar
    All things promised working well for me.
    Opera Mobile working nicely,
    Newest Skyfire beta even more nicely.
    Still liking Opera Mini as a fast and simple image and text browser.
    Definitely notice a speed increase on usb connection.
    My BT functions are back,
    and no lockups yet.
    Haven't tried Shell yet, don't really use it.
    My Redfly is getting closer and closer to what I imagined it would be when I bought it.
    Been tinkering for about 3 hrs now. I will keep updating as I find more benefits / issues.

    Nice job so far Celio.
    02-13-2009 11:07 PM
  3. mknollman's Avatar
    PS - TCPMP will now open and display video. In former versions of the firmware it wouldnt even try and render. In native resolution (my vids are @ 320x240 from my mogul still) they play with a more than acceptable frame rate for watching. When I try and strech to fill the screen, I begin losing frame rate quickly.

    I know this is not a viable use yet, as the size of the vid on my redfly is barely the size of my phone screen. But I am going to play with resolution, quality, and various other things in Sompy encoder and SPB pocket DVD to see if I can get to something watchable. I'll update if I get there. Others please try as well.

    Maybe as they get this compression fine-tuned we might be able to get this think working as a media player after all (without the special devoted cable). Or maybe I am dreaming - lol.

    Again - nice job Celio - don't stop now guys!!
    02-13-2009 11:32 PM
  4. mknollman's Avatar
    Just ran into my first bug - Live Search will not render a map for me. As soon as I ask it to show a map I lose connection the the RF (usb or bt). Google Maps works, but I do not like it as much. So far I would say the ups still outweigh the downs, but I do want my Live Search back.

    By the way - what GPS mapping software (besides the 2 above) are you guys using? Definitely willing to shop around - thanks.

    I will keep plugging away and trying things with the new firmware - seems odd that JUST Live Search is broken.
    02-14-2009 10:00 AM
  5. cuzlion's Avatar
    93 is working fine for me, remember you have to load both the phone drivers and the Redfly firmware, for some reason I couldn't find them next to each other like they used to be(the hyperlinks I mean). Have not tried the new Skyfire or TCPMP but that sounds exciting. Off to find the new Skyfire beta now. Cuz
    02-14-2009 05:27 PM
  6. ckj's Avatar
    Update to build 93 details...

    We've found that SPB Mobile shell is actually not working on a few phones, but working on others. If SPB is not working for you, we'd appreciate you posting here with your phone model and carrier (also note if you're using an unlocked phone or a cooked ROM) so we can get the data to our internal testing team.

    The error messages are very rare, usually tied to a Sprint Touch Pro. If you are getting any of the error messages below, usually you can hit "ok" and proceed as normal. If the messages bug you, contact me and I can email you the previous beta builds to downgrade your software for now. We're talking with HTC to see what can be done.

    Anyone seeing the error codes (especially if you notice any sound issues) please use the personal message feature in the forum to send me your contact info and I'll have our engineering dept contact you directly to trouble shoot.

    These are the codes we've seen so far...

    m11 Fatal Error
    oncrpcxdr_std.c line 542

    or


    Arm11 Fatal Error
    oncrpc_xprtrtr.c line 674

    or

    Arm11 Fatal Error
    oncrpc_cb.c line 146
    02-16-2009 12:20 PM
  7. phildro's Avatar
    Hey there,

    I have the 93 driver/fw combo and like all the progress that has been made. A couple observations that I wanted to run past everyone to see if you have seen similar behavior:

    1) The BT stack gets corrupted sometimes and needs to be restarted in order to connect. This is true for an in-car Microsoft Sync system as well as a BT headset. Stopping and starting the BT service in my Sprint TP gets it working again.

    2) This may have been reported elsewhere, but sometimes my Opera session loses "clickability" with the mouse from the 'Fly...I can use the directional arrows and Enter key to navigate but the mouse movements don't correspond to what I want to click...as if the cursor is not aligned with where its supposed to be.

    Think that's it for now...much better than before, certainly!
    02-25-2009 11:26 AM
  8. graham.hughes's Avatar
    Largely, 93 seems to work fine. Except: I've had some BT drop-outs, and wifi drop-outs. Also, a message about "corrupt video". At this point, the Redfly disconnects.

    One on occasion, the phone (vanilla TouchPro) was left with the screen disabled, and I had to soft-reset the phone. I'm now left with the small fonts on the Today screen, and in Outlook.

    Anyone have any idea what registry settings get changed for these fonts? Re-connected and disconnecting the Redfly doesn't fix it.

    Cheers,
    Graham.
    03-10-2009 05:08 AM
  9. mknollman's Avatar
    Go to:

    start - settings - system tab - screen - text size tab

    The default size is the second positon from the right. This happens to me once in a while and I have noticed it is only when the RF disconnects "ungracefully". I end up with TF3D off and text size small. I have found that sometimes if I am reconnecting the RF that if I do that and then let it shut off and d\c properly it may go back on its own.
    03-10-2009 08:38 AM
  10. graham.hughes's Avatar
    Gah! That simple? I spent last night scouring the registry looking for changes!! :) Serves me right for being a smart arse. Thank you!
    03-10-2009 08:42 AM
  11. dsteinschneider#AC's Avatar
    I uninstalled the previous beta from my Touch Pro because it was exhibiting the arm error on bootup and lots of odd things were occuring such as lockup after playing video in HTC Album.

    Everything is working nice and snappy on my Verizon Touch Pro, faster even then the official release on my previous phone.

    I'm not too concerned about the "meatball effect". If I'm going to be working for a while with the Redfly I run RealVGA and switch to 128 dpi. Perhaps you could incorporate RealVGA and assign it to a button on the Redfly keyboard. The user would press the DPI key when they are going to be working connected to the Redfly for more than a few minutes. When the user disconnects the Redfly the phone reboots back to 196 DPI. That seems practical to me but I guess reviewers will see it as a kluge. Perhaps HTC could develop some type of direct screendraw mode for you that solves the problem.

    Browsing is fine with Opera, for other applications the small font is working. I have a time billing app that is displaying at the larger size but all fields are accessible so I can make my entries.

    Nice that HTC Album is now working. Remote desktop doesn't constantly redraw as it did in the last beta.

    Great work!

    Doug
    Last edited by dsteinschneider; 03-15-2009 at 11:17 AM. Reason: mistake
    03-15-2009 10:28 AM
  12. ckj's Avatar
    A new beta build was posted today (build 147) see http://www.celiocorp.com/install/beta to install and for a change log of what's new. Let us know what you think.

    Make sure to update the firmware on your REDFLY to 147 also.
    03-19-2009 03:43 PM
  13. mknollman's Avatar
    I realized that I have been posting on the wrong thread about the TP drivers. I like the new drivers and love the compression. Here are my issues:

    -spontaneous d/c that requires soft reset when using Live Search Mapping (works with google maps though)

    -phone dialer opens and then closes upon connection

    -BT will not allow connection, I get the "you BT connection must be turned on before authorizing" error, eventhought my BT is on. This has been in issue since I switched to the 93 driver and remains with 147

    Other than those 3 (the BT one being the most annoying) I am very happy with the state of the beta, and I appreciate the constant progress from the folks at Celio.

    Off topic - I am looking forward to trying your software solution - viewer - here in a few days.
    03-27-2009 04:13 PM
  14. graham.hughes's Avatar
    Looking at the 147 change list:

    "[Touch Pro]: If you normally have TouchFLO turned off, the longer delay to load the screen has been eliminated"

    I have a Touch Pro, with TouchFLO switched off. The delay to switch to the RedFly is the same as before, and there is now a much longer delay when switching back to the handset. The delay on switching back is long enough that I thought the handset had crashed, on the order of 5-10 seconds.

    (I have to think that the change in font size on the Today screen is a little pointless, since it doesn't change the status or softkey bar sizes. The Today screen is no more useful, as the icons are still huge. Outlook is slightly better. If the cost of the automatic font switching is huge delays every time I switch between RedFly and handset, I'd love to be able to switch it off.)

    I haven't tried the compression.

    Other than the disconcertingly long switch-over time, this build seems quite stable.

    Cheers,
    Graham.
    03-28-2009 06:32 AM
  15. bioart#WP's Avatar
    If I'm going to be working for a while with the Redfly I run RealVGA and switch to 128 dpi. Perhaps you could incorporate RealVGA and assign it to a button on the Redfly keyboard. The user would press the DPI key when they are going to be working connected to the Redfly for more than a few minutes. When the user disconnects the Redfly the phone reboots back to 196 DPI. That seems practical to me but I guess reviewers will see it as a kluge. Perhaps HTC could develop some type of direct screendraw mode for you that solves the problem.
    I like this idea a lot and seems like an easy implementation... would be a little kludgy, since it would take a little time while waiting for the reboots, but it is convenient...
    03-28-2009 08:18 AM
  16. anon159272's Avatar
    After installation and removal of the latest build (163) my large Touch Pro soft menus are not working anymore (example: go into inbox and choose the "menu" right softkey - the menu used to come up in a large, touch-friendly size; now it comes up the stock size).
    04-03-2009 12:21 AM
  17. Boo Radley's Avatar
    I just updated from 147 to 163 and I've gotta say I'm not too impressed. For starters, the TouchFlo interface isn't working anymore. The phone shows the landscape view but then switches TouchFlo off before going to the RF. I've tried turning TF on in the settings but that just causes my Sprint TP to freeze. TF3D also doesn't turn back on when I disconnect from the RF. I actually have to do a soft reset for it to turn on at all. I'm also getting the ARM11 errors again which I didn't see at all while using 147 drivers.

    For the time being I'm hopeful another decent build will be coming out soon considering how they've been progressing lately. Despite this disappointment, keep up the good work on developing this product.
    04-05-2009 07:56 PM
  18. anon159272's Avatar
    Boo Radley, be sure you're not running AE Button Plus - since the TP has funky hardware buttons, it seems that a lot of folks are using that program and it is incompatible with the Redfly driver. I was getting ARM11 errors when I had it installed.

    Also, TF3D is *not* designed to work on the Redfly. The Redfly driver disables it on purpose when you connect. The Redfly driver switches TF3D off on purpose before connecting to the Redfly, and then turns it back on when you disconnect (at least it does on mine). Since you're getting errors, something isn't compatible and it's not surprising that TF3D isn't being turned back on properly when you disconnect.
    04-05-2009 11:24 PM
  19. Boo Radley's Avatar
    Haus:
    I know that AE Button Plus isn't the problem...I actually had to do a search since I didn't even know what it was. In light of that, I'm really not sure what could be incompatible. The only things I've installed in the last month were the 147/163 builds and firmware.

    And regarding TF3D, I realize the typical *portrait* interface isn't compatible with the Redfly. Heck, even if it was I'm sure it'd be horribly slow considering it doesn't even work smoothly on the TP. What I was referring to was the screen showed when TF3D is on and the TP is in *landscape* view (keyboard open). This is the interface I had when using the previous driver, as opposed to the standard WinMo screen. I just preferred that appearance and found it more user-friendly. That is the main reason I bought the phone, after all, since I got the benefits of WinMo without feeling like I was using WinMo (I switched over from PalmOS).
    04-06-2009 07:09 AM
  20. laurieny's Avatar
    Boo please email me at Laurie@CelioCorp.com as I have an option for you to try.

    -Laurie

    Director of Engineering
    Celio Corp | REDFLY
    04-06-2009 08:07 AM
  21. anon159272's Avatar
    Haus:
    What I was referring to was the screen showed when TF3D is on and the TP is in *landscape* view (keyboard open). This is the interface I had when using the previous driver, as opposed to the standard WinMo screen.
    Laurie, can you or someone comment on this? I've never gotten any part of TF3D working (portrait or the dumbed-down landscape version) while connected to the Redfly. I thought the Redfly driver disabled TF3D entirely. When I'm connected to the Redfly I see the standard WinMo today screen along with the "My First Phone" look.
    04-06-2009 12:46 PM
  22. Litt's Avatar
    Okay, I'm about ready to give up on this whole thing. My TouchPro no longer connects to my Redfly. I can't update the Firmware on my Redfly. No matter what updates I do to my phone it always reads:
    Firmware Version 1.4.0.72 (the software version changes with each of the million different versions I have tried).

    I've soft rest, I've removed the program, I've deleted the files, I have deleted the folder, I have changed the cable. None of these work. I'm on the stock Sprint Rom.

    I had the Redfly working for 2 months. I loved it. I would get positive comments from everyone who saw me using it, but now it is a brick.

    Sorry if this sounds uber-negative, but I've tried everything I can think of and I am stuck (and if I have to re-install the software and soft reset my phone one more time tonight I think I might scream).

    Please, someone help.
    04-06-2009 09:18 PM
  23. Boo Radley's Avatar
    I hate to say it but your best bet may be to hard reset your phone and then try putting on the latest build (72 is a bit old after all :)). I recall having troubles with that build and was about ready to give up on it. In the end I just had to run the firmware cab again to get it working right. However, if you aren't able to get anything working through your TP, a hard reset may be your only option. I know from experience its a pain in the :censored: but sometimes you have to regress before you can progress.

    I know that's not what you want to hear so hopefully someone else here will have a better response for you.

    And on a side note, the more I use my Touch Pro the more I find the abbreviation fitting. If it weren't for my Redfly (and if Sprint had something better), I'd have ditched it by now.
    04-06-2009 10:34 PM
  24. Litt's Avatar
    Thanks, yeah the idea of a hard rest makes me shutter. I truly hope that isn't my best solution. It seems odd that after removing the program and deleting every Celio file I could find that when everything was reinstalled that the Firmware still comes up as 1.4.0.72. I've got to think there is some sort of hidden file that can be removed to help me start over. Perhaps it is all wishful thinking.
    04-06-2009 10:48 PM
  25. mknollman's Avatar
    For troubleshooting I see 2 options.

    1. get ahold of someone else approved winmo phone and try to connect it to gthe RF

    2. use sprite or spb backup and make an image of your TP then hard reset. install ONLY the redfly software, and try to connect. If it works you are good - if not restore the backup.

    If neither of the above work I would say you have yourself a defective Redfly my friend.
    04-07-2009 06:57 AM
127 ... 3456
LINK TO POST COPIED TO CLIPBOARD