The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. slimcane's Avatar
    DISCLAIMER: This works for me and I am posting this as an FYI only. I am not responsible for any mal effects on any hardware or software as a result of editing system files or registry entires.

    Originally this problem surfaced when I was using Opera Mobile on my Sprint Touch Pro 2. Every time I tried to edit a field on a webpage from Opera Mobile, I was being kicked out of the text box thereby preventing me from typing anything. I tried multiple webpages to no avail. I tried sliding out my phone's keyboard first and then starting up Opera and the problem completely disappeared!

    This led me back to the AppAdapt.xml file for the Redfly initialization. There is a registry key being changed for the keyboard sliding out that is causing the issue. Here is the original block of code:

    [CODE] <RegistryChange comment="SetSlideOut(1)">
    <When>connect</When>
    <Operation>save_and_set_value</Operation>
    <KeyRoot>HKEY_LOCAL_MACHINE</KeyRoot>
    <KeyName>System\CurrentControlSet</KeyName>
    <SubKeyName>Keypad</SubKeyName>
    <ValueName>IsSlideOut</ValueName>
    <ValueType>REG_DWORD</ValueType>
    <ValueData>1</ValueData>
    </RegistryChange>[/CODE]

    When I checked my registry, this line was creating a registry value in \HKLM\System\ControlSet\ for "IsSlideOut" versus changing the key value in \HKLM\System\ControlSet\Keypad\ for "IsSlideOut". I figured that the XML file was having difficulty with the "SubKey" definition and therefore was not actually going to that subkey.

    Here is my new section from the AppAdapt.xml that works perfectly after a soft reset:

    [CODE]
    <RegistryChange comment="SetSlideOut(1)">
    <When>connect</When>
    <Operation>save_and_set_value</Operation>
    <KeyRoot>HKEY_LOCAL_MACHINE</KeyRoot>
    <KeyName>System\CurrentControlSet\KeyPad</KeyName>
    <ValueName>IsSlideOut</ValueName>
    <ValueType>REG_DWORD</ValueType>
    <ValueData>1</ValueData>
    </RegistryChange>[/CODE]


    On a side note, I changed a few settings in Opera so that you can fully interact with webpages without having to zoom in. This makes it much better when using Opera on the Redfly.
    Here are my current settings in the opera.ini file:
    [CODE][Adaptive Zoom]
    Browser Buffer Height=1400
    Browser Buffer Width=800
    Maximum Zoom=100
    Minimum overview Zoom=100
    Minimum Zoom=170
    Virtual Screen Width=800
    Zoom Slider Maximum=200[/CODE]

    These settings can also be changed by typing in "opera:config" into Opera Mobile's address bar.
    Last edited by slimcane; 12-15-2009 at 09:10 AM.
    anon159272 and jfa1 like this.
    12-10-2009 08:15 AM
  2. ckj's Avatar
    Nice find. Thanks.
    12-10-2009 02:17 PM
LINK TO POST COPIED TO CLIPBOARD