The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. Andy620's Avatar
    When i open any webpage in microsoft edge in my w10m (Lumia 640 xl with official w10m build 10586.218) and start to scroll up and down, the webpage stutters a lot and sometimes it becomes completely blank. The only way to get that webpage to normal is by entering the tabs view and then re-opening the current tab or zoom in and out inside that webpage. I have been facing this issue since a long time (since insider build 10586.63). Did a hard reset couple of times after updating to newer builds but that didn't help. Therefore rolled back to the official release but the issue is still there. Is anyone here facing this problem and is there any fix for this problem?

    Note: I am using Lumia 640 xl dual sim official release build 10586.218
    Ural Kavraal likes this.
    04-21-2016 09:52 AM
  2. Chintan Gohel's Avatar
    When i open any webpage in microsoft edge in my w10m (Lumia 640 xl with official w10m build 10586.218) and start to scroll up and down, the webpage stutters a lot and sometimes it becomes completely blank. The only way to get that webpage to normal is by entering the tabs view and then re-opening the current tab or zoom in and out inside that webpage. I have been facing this issue since a long time (since insider build 10586.63). Did a hard reset couple of times after updating to newer builds but that didn't help. Therefore rolled back to the official release but the issue is still there. Is anyone here facing this problem and is there any fix for this problem?

    Note: I am using Lumia 640 xl dual sim official release build 10586.218
    What if you change the scaling settings in display? It might make the experience better

    Also, in edge, under settings you should have website preference (either mobile or desktop). Could you change that and test to see if it works better?
    04-22-2016 01:46 AM
  3. jsooney's Avatar
    I have the same problem on my 640, same build as you. Edge is really abysmal, it just doesn't work very well. I haven't come across any websites that it works well with. Some are semi-usable for a few minutes, and some are totally unusable. WPCentral falls into the latter category. I don't know what the problem or fix is. I did try UC Browser for a bit but that was lousy too, so maybe it has more to do with the OS than the browser.
    04-22-2016 08:06 PM
  4. Chintan Gohel's Avatar
    I have the same problem on my 640, same build as you. Edge is really abysmal, it just doesn't work very well. I haven't come across any websites that it works well with. Some are semi-usable for a few minutes, and some are totally unusable. WPCentral falls into the latter category. I don't know what the problem or fix is. I did try UC Browser for a bit but that was lousy too, so maybe it has more to do with the OS than the browser.
    Could you share some of the websites where you have issues in? I would like to test them out on my phone when I get home tomorrow using edge. I don't use edge but I would like to see what these issues are myself.

    Thank you
    04-23-2016 01:03 AM
  5. jsooney's Avatar
    Could you share some of the websites where you have issues in? I would like to test them out on my phone when I get home tomorrow using edge. I don't use edge but I would like to see what these issues are myself.

    Thank you
    Hi, one problematic site is guardian.co.uk. It's pretty bad with Edge, but I'm not sure how much of it is the site and how much is the browser. I've noticed that ad-heavy sites (like this WPCentral) tend to perform worse. There are others but that's the one that springs to mind.
    04-26-2016 08:23 PM
  6. magicdesign's Avatar
    Hi, one problematic site is guardian.co.uk. It's pretty bad with Edge, but I'm not sure how much of it is the site and how much is the browser. I've noticed that ad-heavy sites (like this WPCentral) tend to perform worse. There are others but that's the one that springs to mind.
    I find that windows central/ crackberry just ends up freezing edge on the 1520. Makes browsing totally unusable. Lots of sites behave the same. Also, sometimes have to hit links more than three times before they respond (same as back button). Nothing is wrong with the touch screen, I think it is more to do with the fact that each time it loads an advert, it registers it as a new page.

    I take my sim out and plug into a Nexus 6 or iPhone and browsing is smooth and uninterrupted.

    With adblocking too, but that's another issue...
    05-02-2016 02:29 AM
  7. jsooney's Avatar
    I find that windows central/ crackberry just ends up freezing edge on the 1520. Makes browsing totally unusable. Lots of sites behave the same. Also, sometimes have to hit links more than three times before they respond (same as back button). Nothing is wrong with the touch screen, I think it is more to do with the fact that each time it loads an advert, it registers it as a new page.

    I take my sim out and plug into a Nexus 6 or iPhone and browsing is smooth and uninterrupted.

    With adblocking too, but that's another issue...
    That sounds much like my experience. I find Edge is almost completely worthless with many sites. I'd love to know what fool is developing this thing, it's laughable. Hopefully they don't get paid much. I do think the OS itself might be part of it as it tends to be pretty laggy itself. Still, it is a pre-release so I guess I can't complain too much.

    I bought a Raspberry Pi and I'm going to install Pi Hole on it and see what that does. It is a network-wide ad blocker so I'm curious to see if that makes any difference. It won't help when on cellular networks though.
    05-03-2016 10:44 PM
  8. Denis V's Avatar
    When i open any webpage in microsoft edge in my w10m (Lumia 640 xl with official w10m build 10586.218) and start to scroll up and down, the webpage stutters a lot and sometimes it becomes completely blank. The only way to get that webpage to normal is by entering the tabs view and then re-opening the current tab or zoom in and out inside that webpage. I have been facing this issue since a long time (since insider build 10586.63). Did a hard reset couple of times after updating to newer builds but that didn't help. Therefore rolled back to the official release but the issue is still there. Is anyone here facing this problem and is there any fix for this problem?

    Note: I am using Lumia 640 xl dual sim official release build 10586.218
    Same build, same issue, same pain.

    Also have applications crashing for no particular reason, spent 30 minutes trying to put here screenshot with edge stuttering, but pictures app just crashes when i open it (even when i'm attaching image to a letter in outlook).

    Looks like windows 10 mobile is a most bugged platform ever created by human race.
    05-04-2016 04:07 PM
  9. Denis V's Avatar
    Could you share some of the websites where you have issues in? I would like to test them out on my phone when I get home tomorrow using edge. I don't use edge but I would like to see what these issues are myself.

    Thank you
    IMDb, kinopoisk, jetta club, etc

    Attaching some screenshots to post
    P.s.
    I had to use wire like those medieval savages
    Attached Thumbnails wp_ss_20160504_0001.png   wp_ss_20160504_0003.png  
    05-04-2016 04:16 PM
  10. jsooney's Avatar
    I don't know if it's a fluke, but Edge seems to be working better today. Maybe someone heard my whining. It could just be temporary.
    05-04-2016 06:12 PM

Similar Threads

  1. W10M build 14327 apps are stuck in update, how can I get it to finish?
    By Windows Central Question in forum Windows 10 Mobile
    Replies: 2
    Last Post: 04-26-2016, 08:09 AM
  2. Sign up to test the alpha version of Cliff Bleszinski's next FPS, LawBreakers
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 04-21-2016, 09:50 AM
  3. brightness control issue
    By rolantos in forum Microsoft Surface Pro 4
    Replies: 0
    Last Post: 04-21-2016, 09:44 AM
  4. The Daily Mail's This is Money section is now a Windows 10 PC and Mobile app
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 04-21-2016, 09:30 AM
  5. Verizon reports $32.2 billion in revenue, nets 640,000 postpaid additions in Q1 2016
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 04-21-2016, 09:30 AM
LINK TO POST COPIED TO CLIPBOARD