1. pippyo03's Avatar
    I have had my Lumia950 for about two months now. For the past three weeks or so I have had aproblem charging with my phone through the USB-C quick charge. If the phones at30% I will plug the phone in and it will charge to around 60% in about 5minutes. Then the percentage will jump to 100% and just stop charging alltogether. I unplug the phone and it jumps back down to 64%. plug it backin and it either jumps back to 100% a couple minutes later or just staysat 60%. I do a soft reset and then the phone will read something like 40%. Thenit will either charge ungodly fast and jump to 100% or stay at 40%...

    Its a vicious cycle.The phone never seems to actually know what the battery'scharge percentage truthfully is and then glitches by jumping to 100%whenever it realizes it had no clue what the battery percentage it.

    Some informationwhat cords and other info that one might need. I'm using the wall charger thatcame with the device and I have tried multiple outlets. I've also tried adifferent cord, (the one provided with the continuum dock). Now when I plug thephone into a computer with the usb-usb-c cord (provided by Microsoft) the phonecharges normally but at about the fourth of the pace. Also when I plug thephone into my battery pack, the DC-34 made by Microsoft, It charges normally. Ionly have problems with the wall charger.

    IMPORATANT! I firststarted to have this problem when I tried out my wired continuum dock. Ibelieve this is where the problem originated but I have no idea why ithappened or how to fix it. I haven't used my continuum dock for the past two weeks hoping thatit would resolve the issue but the issue continues, and from what I can tellits worsened. (Although that could just be from mounting frustration)

    Has anyone elseexperienced this problem and knows a fix? Or Any advice on what I could try tosolve the problem. Thank you!
    01-22-2016 05:56 AM
  2. charliekrad's Avatar
    Have you tried to fully discharge the phone till it turns off and then fully charge it to calibrate the battery, this may resolve the issue.
    TheChazas likes this.
    01-23-2016 04:42 AM
  3. pippyo03's Avatar
    Have you tried to fully discharge the phone till it turns off and then fully charge it to calibrate the battery, this may resolve the issue.
    Many of times
    01-23-2016 07:17 AM

Similar Threads

  1. [Quick Impressions] Who just got the Tobii EyeX?
    By Indistinguishable in forum Windows Hello
    Replies: 1
    Last Post: 08-03-2016, 01:45 PM
  2. USB device not recognized
    By Sumukh Phalle1992 in forum Ask a Question
    Replies: 29
    Last Post: 01-23-2016, 07:29 AM
  3. Partial Charging?
    By Michael Sammels in forum Microsoft Lumia 950 XL
    Replies: 4
    Last Post: 01-22-2016, 02:24 PM
  4. Tobii EyeX Bugs + Defects
    By Indistinguishable in forum Windows Hello
    Replies: 0
    Last Post: 01-20-2016, 05:44 PM
  5. Strange bug with win10m and outlook
    By schwarze_Pest in forum Windows 10 Mobile
    Replies: 0
    Last Post: 01-20-2016, 12:35 PM
LINK TO POST COPIED TO CLIPBOARD