Windows 10 causing Photoshop Elements glitch

PilgramHiker

New member
Jul 15, 2022
8
0
1
Visit site
Operating System: Windows 10 (NT?)
Version: 6.2
System architecture: AMD CPU Family:15, Model:0, Stepping:1 with MMX, SSE Integer, SSE FP
Built-in memory: 2048 MB
Free memory: 2048 MB
Memory available to Photoshop: 1695 MB
Memory used by Photoshop: 50 %
Image cache levels: 4
Use image cache for histograms: No
Serial number: 10574317226649478046
Application folder: C:\Program Files (x86)\Adobe\Photoshop Elements 2\
Temporary file path: C:\Users\NE\AppData\Local\Temp\
Photoshop scratch has async I/O disabled
Scratch volume(s):
Startup, 930.78 GB, 819.80 GB free
Primary Plug-ins folder: C:\Program Files (x86)\Adobe\Photoshop Elements 2\Plug-Ins\
Additional Plug-ins folder: C:\Program Files (x86)\Adobe\Photoshop Elements 2\Plug-Ins\
Installed plug-ins:
3D Transform 2.0
ADM 2.84pe69 02.06.17-00:03:36h
ASDStrm 1.02x7 02.02.15-01:45:06h
Accented Edges 7.0
Acrobat TouchUp Image 7.0
Angled Strokes 7.0
Attach to E-mail 2.0x107
BMP 7.0
Bas Relief 7.0
Chalk & Charcoal 7.0
Charcoal 7.0
Chrome 7.0
Clouds 7.0
Color Halftone 7.0
Color Variations 2.0
Colored Pencil 7.0
CompuServe GIF 2.0
Conditional Mode Change 2.0
Contact Sheet 2.0
Conté Crayon 7.0



Pardon me while I (again) say nasty things about MS Windows 10 . . . !

What now? When editing a photo in PhotoshopElements (for example, using the magnetic lassor tool), the screen will suddenly "jerk" -- and the tool will "complete itself" even though I'm not done with the draw.

Please: Anyone have any information about what the problem is and how to stop this from happening?



Thank you. Appreciated.
 

HoosierDaddy

Well-known member
May 28, 2013
2,334
65
48
Visit site
I wouldn't be surprised about unusual problems for PSE 2 on Windows 10. Neither MS nor Adobe say its compatible:

Adobe said:
Are Elements applications supported on Windows 10?Yes. Photoshop Elements 14, Premiere Elements 14, and later versions are compatible with Windows 10.


I know some people use it on W10 but that doesn't mean everything will work right all the time with any particular combination of hardware software.

If I were you, I wouldn't rule out a possible mouse issue, either hardware or driver. I had that same symptom with lasso with a much newer version of PSE many years ago that turned out to be phantom clicks. New mouse fixed it. May not be your problem but trying another mouse may be worth a shot.
 

Members online

No members online now.

Forum statistics

Threads
323,762
Messages
2,244,335
Members
428,116
Latest member
ayaan