09-12-2016 12:40 AM
27 12
tools
  1. bostonguy's Avatar
    Hey Surface Experts!

    I've just joined the club. I recently picked up an S3 with 4gb/128gb and LTE, pen and keyboard. I'm really loving it so far. It had Windows 10 out of the box. I had one of the original Asus t100's back when they first hit, but the size, speed, RAM and lack of LTE doomed it as a keeper for me. This Surface 3 is just about perfect (if only it had SSD for better disk speed) for most day to day things I do.

    However I have a problem. I cannot for the life of me get hibernate to work or even show up as an option. I've googled every which way, tried all the tricks to get the hibernate option to show/work but no luck. Now I swear it was there and working when I first booted/setup my S3. But as usual, my first few setups of my new device went awry so I "recovered" (fully wiping) since then and NO hibernate option.

    I'm thinking I might have gotten a MS BIOS update during that first setup that somehow disabled hibernate. I don't even know how to get into the BIOS at boot to be honest. When I run "powercfg /a" it doesn't show hibernate as an option. It says "the hiberfile does not support hibernation". It says "S0 Low Power Idle Network Connected Fast Startup" is supported. If I run the proper powercfg commands I can turn off hibernate (which deletes the hiberfile.sys file) and turn it back on (which recreates the file) but it never actually works or shows as an option in the Control Panel Power GUI. Also not my hiberfile.sys is about 800MB in size which is not the expected size on a 4gb system.

    I even tried setting it up w/o the SD card and SIM card to see if they were affecting it. No luck.

    Anybody have any ideas or seeing anything similar with S3 and Windows 10?

    Thanks!
    10-02-2015 08:21 AM
  2. suburbanl3g3nd's Avatar
    I got mine to show in the power options by going to the control panel (not settings app) and going into the power settings. On the left side of your window will be an option called 'choose what closing the lid does.' In that option, there is an option to change settings that are currently unavailable. After you tell it you want to change settings, the hibernate check box can be clicked. And then hibernate should be in your power options
    10-02-2015 08:25 AM
  3. bostonguy's Avatar
    Yup, everybody says that. Doesn't work. When I go into that area (which I disable the password function) it only ever has three options for closing the lid - Turn On Fast Startup, Sleep, Lock. No hibernate option anywhere. Again, I've done two FULL wipes and recoveries, no change. I've read every damn MS and other articles I can find about the hibernate option, nothing has worked. I'm stumped. I may call MS and get a ticket opened. I'm about out of ideas.
    10-02-2015 08:40 AM
  4. suburbanl3g3nd's Avatar
    Try this link's advice: http://johnsonyip.com/wordpress/2009...ws-vista-or-7/

    I've had success when it wasn't an option on my surface 3 by another command prompt entry that I'll try and dig up, too.
    10-02-2015 07:08 PM
  5. suburbanl3g3nd's Avatar
    Also, consider trying the "powercfg.exe /hibernate-timeout-ac (minutes)" and the "powercfg.exe /hibernate-timeout-dc (minutes)" commands in the command prompt with admin controls.

    This page explains a boatload more than you'd ever want to know about powercfg.exe on the command prompt: https://en.wikipedia.org/wiki/Powercfg
    10-02-2015 07:22 PM
  6. bostonguy's Avatar
    I couldn't get "powercfg.exe /hibernate-timeout-ac (minutes)" or the other to work. They aren't listed when you do a "powercfg /?" so maybe they were Windows 8 not 10? Anyway, as I said I've tried all the various command line and registry and even group policy fixes. No luck.

    It acts like it's enabling cause it deletes and recreates the hiberfil.sys if I turn it off - but again it states "file is not valid and hibernate is not supported" when I run a "powercfg /a" which lists all states a given system supports. But I KNOW I had it on my first boot until I wiped and started over. Wen into the BIOS today and messed around with TPM and Secure boot (tried turning each off/on) but again no luck.

    I think the system got flashed/patched by MS to disable hibernate until they figure all the sleep/wake problems with Windows 10. I'm at a loss to explain it not working any other way. I mean I'm starting with a completely secure, totally wiped, rebuilt b\native Windows 10 build here. I just bought the Surface on Tuesday. Oh well, I'll keep looking. Thanks for your help, if you think of anything let me know.
    10-02-2015 08:41 PM
  7. suburbanl3g3nd's Avatar
    Does "shutdown /h" do anything?

    Edit:
    In the command prompt I mean.
    10-02-2015 11:40 PM
  8. suburbanl3g3nd's Avatar
    Also, I downloaded all the surface drivers and fresh installed Windows 10 since mine was upgraded to 10. Idk if it would change anything, but personally, my system is much more agile and smooth since the reinstall. Was a process to get set up. But, worth it in the end
    10-02-2015 11:42 PM
  9. Dewg's Avatar
    Could be a firmware problem, and you might need the surface replaced.
    10-03-2015 01:42 AM
  10. bostonguy's Avatar
    So "shutdown /h" comes back with "not a supported function S0"

    Mine came with Windows 10 as the installed/recovery image, so it never was Windows 8. I have tried full wipes and reinstalls to factory fresh several times now. Even did the secure disk wipe just for kicks. No fix. Last night Windows Update found a firmware update dated 9/15/2015 and even after flashing that, no fix for hibernate.

    I may gor find all the drivers and manually reinstall them. Don't know what else to try at this point. Thanks again for all your help, wish it had worked, but you tried so thanks! :)
    10-03-2015 08:00 AM
  11. heineken016's Avatar
    Hey, did you or anyone else sort this out? Can't find a hibernate option in win10 on my S3.
    10-18-2015 04:07 AM
  12. bostonguy's Avatar
    Yes, got it fixed. After trying everything a guy on another forum found the fix. Not sure if I can link the other forum here, so here's the fix copy/pasta style:

    Start regedit, then navigate to HKLM\SYSTEM\CurrentControlSet\Control\Power. In that key, right-click and export HiberFileType as a backup. After, delete it. Reboot. Hibernate should now appear in your options and work properly.

    Make sure you do this and reboot before the next step. Doing them both at once didn't work for me.

    Now, for additional options, change the CsEnabled key (same place) to 0. Reboot. Now, go to Power Options, Advanced and you can change a bunch of additional settings in the balanced profile. Other profiles will appear, but are only usable at the expense of connected fast startup and sleep. Set the options you want in the balanced profile, then go back to the registry, set the CsEnabled key back to 1. Reboot. The options you set are not shown anymore, but they are still in effect.


    I didn't mess around much with the extra settings stuff, but it's there if you want to. This worked great for me, good luck.
    Last edited by bostonguy; 10-19-2015 at 02:04 PM. Reason: word missing
    icwhatudidthere likes this.
    10-19-2015 02:03 PM
  13. RadicalDad's Avatar
    This is much too complex - why edit the registry if you don't have to? If you don't have the hibernate option on your Surface Pro 3 after a fresh install of Windows 10 (quite likely outcome), stay out of the registry and do this instead. Open an elevated command prompt. Then type

    powercfg /h /type full

    This expands the size of the hibernation file (hiberfil.sys) to 75% of your installed RAM. With smaller SSD's, I guess the default is to keep the hibernation file small (allows only for fast start option).

    As for bostonguy's assertion that you can undo connected standby (CS), set power options that aren't available with CS, then re-enable CS and have the options stick - it just doesn't work that way. Don't waste your time.
    Rotterdaam likes this.
    11-18-2015 05:13 AM
  14. oditius's Avatar
    This is much too complex - why edit the registry if you don't have to? If you don't have the hibernate option on your Surface Pro 3
    So what you are saying is the Surface Pro 3 operates just like the Surface 3? Interesting, the S3 being less powerful than the SP3, but it's shortcuts are the same... That's good to know...
    11-18-2015 05:37 AM
  15. BaritoneGuy's Avatar
    Here is the way I did it on my Surface pro 3 and Dell Venue
    Show Hibernate in Power Options Menu in Windows 8
    11-18-2015 10:45 AM
  16. icwhatudidthere's Avatar
    The latest Windows 10 update seems to have fixed my hibernate issue. I didn't have it since I bought it (came with Windows 10) but after last week's update, it showed up. Also seems to work perfectly now. I can finally let it sleep overnight and not wake up to a dead battery.
    11-18-2015 11:28 AM
  17. neo158's Avatar
    Hybrid Sleep, named Sleep, is the replacement that has elements of both Sleep and Hibernation. The main problem I had with hibernation is that it is barely any quicker than a cold boot.
    11-19-2015 07:38 AM
  18. bockersjv's Avatar
    Hybrid Sleep, named Sleep, is the replacement that has elements of both Sleep and Hibernation. The main problem I had with hibernation is that it is barely any quicker than a cold boot.
    Barely! I have re-installed an OS I less time than it takes or Hibernate to start up. I never saw the point. What is so wrong with plain sleep, or indeed for the Surface power off.
    11-19-2015 05:35 PM
  19. neo158's Avatar
    Barely! I have re-installed an OS I less time than it takes or Hibernate to start up. I never saw the point. What is so wrong with plain sleep, or indeed for the Surface power off.
    Exactly, it's faster just to use sleep instead
    bockersjv likes this.
    11-20-2015 07:57 AM
  20. icwhatudidthere's Avatar
    Maybe it's just because I've got the LTE version but normal sleep uses lots of power on my device, even after turning off background tasks. It's almost like it's not asleep at all. Only got about 10-12 hours of sleep before. With the latest update and hibernate being re-enabled, it's more like normal.

    Also while hibernate takes a while longer to turn on, a cold boot still takes some more time after you login before it's really ready to use.
    11-20-2015 01:33 PM
  21. Pete Sacomano's Avatar
    This is much too complex - why edit the registry if you don't have to? If you don't have the hibernate option on your Surface Pro 3 after a fresh install of Windows 10 (quite likely outcome), stay out of the registry and do this instead. Open an elevated command prompt. Then type

    powercfg /h /type full
    THANK YOU. I had to dig through so much garbage to find this CORRECT solution. I should have known there were extra parms in powercfg.

    As a note, sleep may be quicker, but Windows has never been very good with sleep, I see systems wake up by themselves all the time. Imagine what kind of damage that can do to a laptop in a bag. Hibernation ensures the system is entirely powered down and is very quick with a SSD.
    12-06-2015 06:41 PM
  22. jack69453's Avatar
    You might also want to view this thread and the linked power management video by Dan.
    http://forums.windowscentral.com/mic...ml#post3288845
    12-07-2015 07:08 AM
  23. Telstar1948's Avatar
    The only other advantage of hibernate over a complete shutdown is if you want certain apps/software/work there when you awake your S3, they will be there coming out of hibernation.
    12-27-2015 12:33 PM
  24. Brian282's Avatar
    If you don't have the hibernate option on your Surface Pro 3 after a fresh install of Windows 10 (quite likely outcome), stay out of the registry and do this instead. Open an elevated command prompt. Then type

    powercfg /h /type full

    (allows only for fast start option).
    Thanks this worked like a charm, but I can honestly see why they disabled the function its buggy as hell on Win 10. It saves you maybe 3 seconds from a cold start, but there is one huge issue. If you enable hibernation on accident. Then try to bring your PC back to life the stupid OS won't come back on line. You have to give it time before it will even come back to life. Its a pain in the ***.

    I swear Windows 10 is my first love hate relationship with Microsoft. I really feel the should of baked the OS for another year before releasing it. 8.0 wasn't even buggy compare to 10.
    12-28-2015 06:23 PM
  25. neo158's Avatar
    I don't know if this might help but it worked for me:

    https://support.microsoft.com/en-us/kb/3092579
    02-06-2016 07:23 PM
27 12

Similar Threads

  1. Replies: 1
    Last Post: 09-28-2015, 05:34 PM
  2. HP Probook 450 G2 Some Function Keys not working
    By Shahroz Naeem in forum General Desktop, Laptop & Tablet Discussion
    Replies: 0
    Last Post: 09-26-2015, 12:07 PM
  3. Replies: 0
    Last Post: 09-25-2015, 09:29 PM
  4. Insider Preview Missing Mail icon in Calendar and Calendar icon in Mail
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 09-25-2015, 07:11 AM
  5. Replies: 0
    Last Post: 09-23-2015, 06:29 PM
LINK TO POST COPIED TO CLIPBOARD