1. infinitylook's Avatar
    SUddenly my USB C hub not working. This is my hub, https://www.amazon.com/UGREEN-Multip...pUvbUpU3771504

    it was perfectly working fine before until i noticed that I can no longer print files from my GO. I tried plugging a flash drive and hard drive and it detected it as well as the microsd cards however printers, mouse and keyboard as well as wifi usb hub wont detect. i tried plugging the adapter to other usb c laptops and it perfectly worked fine, no issues. Now i'm not sure if the issue is hardware on my surface go. IF I plug my usb c flash drive it detects without an issue.
    01-16-2019 08:07 AM
  2. infinitylook's Avatar
    No one has the same problem as mine? Is this more of a hardware or software problem?
    01-19-2019 08:54 AM
  3. HeyCori's Avatar
    Have you tried plugging the hub into the Go, then test each device individually to see if they work?
    01-20-2019 08:34 AM
  4. infinitylook's Avatar
    thank you for replying. Yes I tried plugging each device. Flash drives will detect however printers, wifi adapters and others will not. I thought it was a problem with the HUB i bought (which was perfectly working months prior) until I borrowed another laptop with type C and confirmed that the hub works fine with other types of devices. I'm confused if this is an hardware problem with the Go or a software issue. Do you have a USB C as well?
    01-20-2019 11:04 PM
  5. HeyCori's Avatar
    I have this Anker USB-C hub from Amazon.

    https://www.amazon.com/Anker-Premium...pUvbUpU3771909

    It works fine but the most I've ever had plugged into it was ethernet, keyboard, and hard drive.

    My first thought was maybe the Go couldn't provide enough power to the hub to in-turn power all the devices you had plugged in. That could be why you're getting better results on laptops versus the Go. Usually that could be solved with a powered usb hub.

    But if not that, then you could try reinstalling the drivers for the Go. Unfortunately, you can't download drivers individually, so you would have to install the entire pack.

    https://forums.windowscentral.com/e?...token=89RtYJO-
    01-21-2019 08:07 AM
  6. infinitylook's Avatar
    I also thouht about that reinstalling actually I've done that but still it doesn't work.
    01-21-2019 08:41 AM
  7. infinitylook's Avatar
    can someone confirm that their type c adapter works?
    02-08-2019 08:55 AM
  8. HeyCori's Avatar
    By chance do you have another brand of adapter you can try?
    02-10-2019 07:59 AM
  9. infinitylook's Avatar
    yes and it's the same the surface go will detect usb 3.0 devices such as flash drives and hard drives but not usb 2.0 devices like printers, usb mouses etc. so this means that this is a hardware problem but it's really weird
    02-11-2019 03:08 AM

Similar Threads

  1. Notifications of Windows central app for Android
    By TuanLVT in forum Ask a Question
    Replies: 2
    Last Post: 01-22-2019, 08:21 AM
  2. Netflix stopped working
    By meobeou in forum Ask a Question
    Replies: 1
    Last Post: 01-16-2019, 08:51 AM
  3. Snap up a Fujifilm Instax Mini 9 camera for its best price yet
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 01-16-2019, 05:20 AM
  4. New cumulative updates now available for Windows 10
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 01-15-2019, 05:30 PM
LINK TO POST COPIED TO CLIPBOARD