1. Culture Maaate's Avatar
    I live on my internet. I can play an xbox game online and watch a 480p YouTube video at the same time. Anytime i turn on my Surface 3 it destroys my connection. I can turn abdolutely everything off except my Surface 3 and it can barely load a 144p YouTube video without buffering every 5-10 seconds. What is the cause of this and how can i fix this? it is ridiculous!
    09-26-2017 12:15 AM
  2. ronw1309's Avatar
    I had the equal trouble, down load become around 1 MBPS and add become round 500 KBPS, but spouse turned into over a one hundred MBPS on each with identical pill. I did a tender restart on my surface, lamentably misplaced a bunch of apps but while tablet ultimately restarted home windows stored a record with all my apps that I misplaced, plus it additionally keeps documents, so I went lower back inside the down load folder and reinstalled everything. I now have over one hundred MBPS for both add and download speeds.
    06-09-2018 06:48 AM
  3. RTGent's Avatar
    I'd guess you have a pending update: check your update page. This is the only time(s) I've experienced video interruptions, though what I've experienced is videos stopping with some kind up "can't" popup or message.
    06-09-2020 07:02 PM

Similar Threads

  1. Replies: 4
    Last Post: 09-26-2017, 01:15 AM
  2. Lumia, Surface or ANDROID??
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 09-25-2017, 09:23 AM
  3. Chime in: Should Microsoft's next phone be another Lumia instead of a Surface?
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 2
    Last Post: 09-25-2017, 06:58 AM
  4. Lumia 535 internet not working
    By VPS_004 in forum Windows Phones
    Replies: 0
    Last Post: 09-25-2017, 04:38 AM
  5. Surface Pro not showing estimate time left
    By Loc Ngo in forum Microsoft Surface Pro
    Replies: 0
    Last Post: 09-24-2017, 06:05 PM
LINK TO POST COPIED TO CLIPBOARD