1. Daniel0418's Avatar
    After connecting to my home network it just stays on "limited use" forever. All other tablets and PCs in my house work just fine. I can't figure this out. I turned off the router. I reset it. I chose "forget network" and tried reconnecting. Nothing works. It shows full bars but has the exclamation mark that says limited use. Anyone else having this issue?
    10-26-2012 12:05 PM
  2. mattabar's Avatar
    Having the same problem. I tried everything you did, and also tried connecting by pressing the button on the WiFi router. It still labels the connection as "Limited". I have a DLink DIR-655 router.
    10-27-2012 09:57 AM
  3. NickA's Avatar
    What kind of authentication do you guys have setup for wi-fi? Maybe try changing that and see what happens. Or take it to a place that has free wi-fi and see what happens there.
    10-27-2012 10:52 AM
  4. VagrantWade's Avatar
    Can you screenshot your broadcast wireless settings from your firmware? Blank out the WPA/WEP info before doing it though.
    10-27-2012 10:54 AM
  5. sleepyking's Avatar
    After connecting to my home network it just stays on "limited use" forever. All other tablets and PCs in my house work just fine. I can't figure this out. I turned off the router. I reset it. I chose "forget network" and tried reconnecting. Nothing works. It shows full bars but has the exclamation mark that says limited use. Anyone else having this issue?
    How did you get "forget the network"? On the surface help page it says just select the network and hold and it should give the option, but when I kept trying that nothing happens
    10-27-2012 11:53 AM
  6. Daniel0418's Avatar
    Mine finally started working. Sad thing is, I didn't do anything to fix it. After I couldn't get it to work I began to just tether with my phone which worked fine. My phone lost service so I turned tethering off. Low and behold it auto connected to my home network but this time it worked. Not sure what the issue is. Maybe on some networks it just takes a really long time to authenticate. Sometimes my older PCs would do that with my phones tethering connection.
    10-27-2012 12:01 PM
  7. mattabar's Avatar
    Encouraged by blayze04, I spent 10 minutes resetting, turning on/off the various components and mine just started working too. The magic combination seemed to be holding the Surface (sans keyboard) right next to the router, restarting the router and immediately trying to connect.

    FYI, to "forget the network" you have to hold your finger on the connection, then select "forget this network" from the popup menu.
    10-27-2012 02:19 PM
  8. DrSaiko's Avatar
    I had the same problem. but it was solved right after I unplugged the power from my router for 10 secs and plugged it back.
    10-27-2012 02:36 PM
  9. dkp23's Avatar
    having same issue from time to time, worked fine out of the box. Twice now, my internet would go to limited, i would just go to the wireless setting, disconnect and reconnect and it works. Kind of annoying
    10-27-2012 02:41 PM
  10. TMavC5's Avatar
    Often time your router is the culprit.
    10-27-2012 03:08 PM
LINK TO POST COPIED TO CLIPBOARD