• 00Days
  • 00Hours
  • 00Mins
  • 00Secs
Check out the best deals!
  1. omegafiler's Avatar
    As the title says, I've checked every menu multiple times and can't find any way to stop the annoying "buzz" everytime I press the 3 touch keys at the bottom.

    I found the "touch" menu that says it should have these settings, but nothing in there about this. I did find a few old posts going back about a year for other WP phones having this "issue." But if this hasn't been fixed by now, that's a pretty big oversight in my mind.

    Hopefully I'm just missing something. Anybody else having this issue?
    11-23-2013 01:28 PM
  2. ttsoldier's Avatar
    As of now , no.
    11-23-2013 01:38 PM
  3. akashpats's Avatar
    that's feature might come in Nokia's future updates.
    11-23-2013 01:40 PM
  4. omegafiler's Avatar
    And a little more research has indicated this is a known and reported issue. But no indication from Nokia that there is any plans to have this resolved. So as I just posted in another thread, if something isn't working as it should be, contact their support! Now that I know it's a common issue and it's not user error, that's what I'll be doing on Monday.

    Contact Nokia Support - Nokia - USA

    At the very least, you can vote/add comments here. Even though I think it falls under "defect" versus "feature suggestion." It's a start.

    Please allow users to disable haptic feedback on the main buttons on Windows 8 phone €“ Feature Suggestions for Windows Phone

    UPDATE 11/25: Spoke with Nokia support. They actually suggested exchanging the device, even after explaining this effects all devices. It seems as though they have no idea this is actually an issue.
    Last edited by omegafiler; 11-25-2013 at 10:33 AM.
    11-23-2013 08:36 PM
  5. Ankur28's Avatar
    Hi. If you are still looking for solution, Nokia has finally release update so now we hav eswitch to disable this. Refer to the post in the link below. It works. http://www.windowscentral.com/nokia-...tton-vibration
    Last edited by Laura Knotek; 02-20-2014 at 12:35 AM.
    Laura Knotek and oditius like this.
    02-19-2014 11:50 PM
  6. santhanvg's Avatar
    Hi. If you are still looking for solution, Nokia has finally release update so now we hav eswitch to disable this. Refer to the post in the link below. It works. Nokia Touch update allows you to disable button vibration | Windows Phone Central
    Yes it's working perfectly.
    02-20-2014 11:03 AM
  7. ramin rahimi's Avatar
    i have installed the update but when i want to access the touch in setting it keeps refreshing the setting page, how can i reinstall the update?
    is there any other solution?
    04-02-2015 08:52 AM

Similar Threads

  1. Small issue with touch sensitivity
    By Phrozty in forum Nokia Lumia 1520
    Replies: 20
    Last Post: 12-20-2013, 11:35 PM
  2. Replies: 1
    Last Post: 11-23-2013, 11:54 AM
  3. Xmas list : your companion for you Christmas Shopping
    By Laranzu in forum App Spotlight
    Replies: 1
    Last Post: 11-23-2013, 10:17 AM
  4. How do you turn off facebook chat on 1520?
    By Shockwave78 in forum Nokia Lumia 1520
    Replies: 4
    Last Post: 11-23-2013, 10:15 AM
LINK TO POST COPIED TO CLIPBOARD