1. xxhonkeyxx's Avatar
    First off, I got it from B&h Photo and it works brilliantly. I updated to 8.1 and everything, have had no issues whatsoever with software or anything. I bought it and had it to my door about 3-4 days later.

    That said, I haven't gotten LTE to work yet. The APN seems to be set up correctly (went by both att and Microsoft stores), but I'm only getting H+. I haven't tried a hard reset yet, I may do that tonight

    Do y'all have any suggestions before I hard reset? Different APN settings maybe? It is the RM-938 variant with 1700 band support.

    05-02-2014 06:51 PM
  2. Laura Knotek's Avatar
    I believe the AT&T version is RM-940.
    05-02-2014 11:56 PM
  3. hasasimo's Avatar
    First off, I got it from B&h Photo and it works brilliantly. I updated to 8.1 and everything, have had no issues whatsoever with software or anything. I bought it and had it to my door about 3-4 days later.

    That said, I haven't gotten LTE to work yet. The APN seems to be set up correctly (went by both att and Microsoft stores), but I'm only getting H+. I haven't tried a hard reset yet, I may do that tonight

    Do y'all have any suggestions before I hard reset? Different APN settings maybe? It is the RM-938 variant with 1700 band support.

    A few people on here have noted that you have to call AT&T and ask them to provision your IMEI. For some reason they'll list your phone as some kind of generic non-LTE device. No need to reset, give them a call and explain. Maybe one of the aforementioned members that had the same issue can offer more info.

    Can I ask what color you got? I ordered mine from B&H as well and everything about it is awesome, no issues except for the occasional swipe/tap problem that apparently most people have. I wonder if there's any correlation with device color and the swipe/tap problem. Racist, I know.
    xxhonkeyxx likes this.
    05-02-2014 11:59 PM
  4. xxhonkeyxx's Avatar
    A few people on here have noted that you have to call AT&T and ask them to provision your IMEI. For some reason they'll list your phone as some kind of generic non-LTE device. No need to reset, give them a call and explain. Maybe one of the aforementioned members that had the same issue can offer more info.

    Can I ask what color you got? I ordered mine from B&H as well and everything about it is awesome, no issues except for the occasional swipe/tap problem that apparently most people have. I wonder if there's any correlation with device color and the swipe/tap problem. Racist, I know.
    I got yellow. I haven't noticed any issues with the swipe/tap problem at all on mine, but maybe I just haven't noticed it.

    Do I need to call ATT for the imei switch or can it also be done in store?

    Thanks!
    05-03-2014 02:42 AM
  5. hasasimo's Avatar
    I'm guessing if you go to a store they'll likely have you call customer care from there, but I'm not sure. I believe the other 1520.3 users on here with this problem solved it by phone.
    05-03-2014 02:47 AM

Similar Threads

  1. My Cortana cant recognize music !
    By Hasoumi in forum Cortana
    Replies: 6
    Last Post: 05-04-2014, 12:08 PM
  2. Replies: 6
    Last Post: 05-03-2014, 09:16 PM
  3. Question about 1520 and games
    By littlejay in forum Nokia Lumia 1520
    Replies: 3
    Last Post: 05-03-2014, 04:55 AM
  4. Replies: 23
    Last Post: 05-02-2014, 11:53 PM
  5. Sneak peek at aerial dogfighting game Blazin' Aces for Windows Phone
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 05-02-2014, 04:42 PM
LINK TO POST COPIED TO CLIPBOARD