1. EBynum's Avatar
    My Lumia 2520 has a strange intermittent problem with the system clock. It doesn't always keep the correct time. Some days the clock works fine, and some days it doesn't keep the correct time. Restarting/rebooting doesn't always help. The problem comes and goes without rhyme or reason. For example, all last week it was fine, but yesterday the problem started again. In my Date and Time settings, I have the "Set time automatically" setting set to "On", and the time zone setting is correct. Whenever I wake up the tablet and the clock isn't right, I go into settings, turn the "Set time automatically" setting off, then immediately back on again, and the time automatically updates to the correct time. So I can easily correct the time, but whether or not it will stay correct throughout the rest of the day has been hit or miss. I can correct the time, then wake up the tablet a while later, and the time will be wrong.This has been going on before and after the latest Windows 8.1 update. It's not a horrible problem, but it's annoying. I've never experienced this issue with any of my other devices. I have Lumia 520, 620, 920, and 1520, a Dell Venue 8 Pro, and a Surface RT. None of them have ever had this weird intermittent problem with the clock. Has anyone else experienced this issue with their 2520? Any ideas on what's causing it?
    04-21-2014 11:40 PM
  2. Aanze's Avatar
    Hi, I've got the same problem on my Lumia 1020 with 8.1.
    But I've had this issue with previous WP version, as well as on my previous device (a lumia 920). I think it might be carrier related, I don't know. I'm with Orange in France btw.
    04-23-2014 02:52 AM
  3. ChumsFuture's Avatar
    Used both a 920 and a 1020 on both Straight Talk and ATT and never got this problem.
    04-23-2014 01:33 PM
  4. EBynum's Avatar
    Thanks for the replies. Not sure if the problem is carrier related. My three Lumia phones (620, 920, and 1520) and my Lumia 2520 tablet are all on AT&T (all on same data plan). I have never had this problem on any of my phones. The clock issue only happens on the tablet. If it was carrier related, you'd think I'd have the same problem on the phones, but I don't. Maybe there is something unique about how the tablet connects with the network. As an experiment, I've turned off the mobile broadband connection on the tablet, so now it's only on Wi-Fi. The clock is working fine again now, but I'll have to monitor it for awhile to see if the problem recurs.
    04-24-2014 12:21 AM
  5. cgavula's Avatar
    I posted this same problem over on the Nokia forums. The device sometimes loses time - but not all the time - and it's on AT&T, but none of my other AT&T devices have this problem. It's all set to automatic, but it still loses time sometimes. I can fix it by thurning the automatic to off then back to on, but that shouldn't be necessary, I would think. Its weird. For me, it mostly does it when the device sleeps.
    04-29-2014 07:39 PM

Similar Threads

  1. Project my screen app for Surface RT/2?
    By Jowarman in forum Windows Phone 8.1 Preview for Developers
    Replies: 2
    Last Post: 08-01-2014, 10:35 AM
  2. I need a clock with a double-wide transparent tile
    By Jazmac in forum Windows Phone 8.1 Preview for Developers
    Replies: 18
    Last Post: 05-31-2014, 03:33 PM
  3. Amazing Weather HD updated with trasnparent tiles
    By Baryex86 in forum Windows Phone 8.1
    Replies: 11
    Last Post: 04-23-2014, 03:47 PM
  4. Issues with 'working' Lumia 920
    By Quinn FitzGerald in forum Nokia Lumia 920
    Replies: 8
    Last Post: 04-22-2014, 02:10 AM
  5. Help with app
    By bhast2 in forum Developers Corner
    Replies: 0
    Last Post: 04-21-2014, 08:25 PM
LINK TO POST COPIED TO CLIPBOARD