1. xumit's Avatar
    Hi guys. I got my L520 couple weeks ago. Since the first day, im facing a weird issue. The phone switches off automatically even when it has battery left (26%, 70%, 38% battery left 3 times) and it refuses to switch on! It doesn't reply in any way after pushing start button. Only when I plug it in it shows a battery charging icon after which when i start it it will start normally. This happened 3 times with me. Is this happening with anyone else or im the only one?
    09-09-2013 02:27 AM
  2. Boris Lozac's Avatar
    Does the battery get completely discharged, when you plug it in does it charge from zero or it continues from those 26, 70% etc?
    09-09-2013 04:50 AM
  3. xumit's Avatar
    Does the battery get completely discharged, when you plug it in does it charge from zero or it continues from those 26, 70% etc?
    it continues from where it left of, respective percentages. The problem hasnt occurred in last 2 days though.
    09-09-2013 06:45 AM

Similar Threads

  1. L920 data in Thailand, Cambodia, or Vietnam
    By orangesplease in forum Nokia Lumia 920
    Replies: 2
    Last Post: 12-26-2013, 02:48 AM
  2. Replies: 11
    Last Post: 09-09-2013, 07:26 PM
  3. Windows Phone Desktop App
    By Chris Sandiford in forum Windows Phone 8
    Replies: 3
    Last Post: 09-09-2013, 07:00 AM
  4. Changes upcoming to the Music App in WP?
    By scottwallace5 in forum Groove Music
    Replies: 2
    Last Post: 09-09-2013, 12:14 AM
  5. Calendar app in this picture?
    By tylerfarm in forum Applications
    Replies: 3
    Last Post: 09-08-2013, 10:58 PM
LINK TO POST COPIED TO CLIPBOARD