1. ragnand2905's Avatar
    I have this strange problem while using the sandisk ultra class 10 16 gb memory card on my 520. Whenever I have chosen to save apps on SD card, the store says there is problem with memory card and my phone hangs. And when I boot the phone it says it needs to scan my memory card and then after sometime it says your memory card has irreparable error. please use another memory card. But when I use the memory card with the adapter provided on PC it works fine. What might be the problem on phone? Does 520 not support class 10 memory card? If not which would be the best 16 GB memory card for 520? Thank you in advance :) :)
    05-03-2014 12:43 PM
  2. S Vaibhav's Avatar
    I have this strange problem while using the sandisk ultra class 10 16 gb memory card on my 520. Whenever I have chosen to save apps on SD card, the store says there is problem with memory card and my phone hangs. And when I boot the phone it says it needs to scan my memory card and then after sometime it says your memory card has irreparable error. please use another memory card. But when I use the memory card with the adapter provided on PC it works fine. What might be the problem on phone? Does 520 not support class 10 memory card? If not which would be the best 16 GB memory card for 520? Thank you in advance :) :)
    Copy all the data on the card to PC, format the card, copy the data back from the card to the PC. Problem solved.If not, either there is a problem with the data on the card or the card itself. Try putting the completely formatted card without any data on it in the phone and try installing apps to sd. If it works, then it was a problem with the earlier data on the card. If it direct install apps to sd,it is a problem with the card itself.Go to the store where you bought it and claim your warranty.
    05-03-2014 01:08 PM
  3. ragnand2905's Avatar
    Copy all the data on the card to PC, format the card, copy the data back from the card to the PC. Problem solved.If not, either there is a problem with the data on the card or the card itself. Try putting the completely formatted card without any data on it in the phone and try installing apps to sd. If it works, then it was a problem with the earlier data on the card. If it direct install apps to sd,it is a problem with the card itself.Go to the store where you bought it and claim your warranty.
    Thank you for the quick reply. :)
    I already tried doing what you have told many times. That is copying the data to PC, formatting the card and copying the data back. Also I tried directly installing apps to the formatted memory card. First few apps install and then the same problem. It may not be the problem with the card as I have been using it on my Sony camera to take 18mp pics and videos of 1080p. Have taken many pics and videos using the same memory card with the adapter. And I can also use the card on my laptop without any glitch too. The problem comes only when I use it with my phone. Initially I thought it might be problem with windows phone 8. But even after upgrading to 8.1 and also doing a hard reset I am getting the same problem.
    05-03-2014 01:18 PM
  4. S Vaibhav's Avatar
    Thank you for the quick reply. :)
    I already tried doing what you have told many times. That is copying the data to PC, formatting the card and copying the data back. Also I tried directly installing apps to the formatted memory card. First few apps install and then the same problem. It may not be the problem with the card as I have been using it on my Sony camera to take 18mp pics and videos of 1080p. Have taken many pics and videos using the same memory card with the adapter. And I can also use the card on my laptop without any glitch too. The problem comes only when I use it with my phone. Initially I thought it might be problem with windows phone 8. But even after upgrading to 8.1 and also doing a hard reset I am getting the same problem.
    Test the phone with a spare memory card to see if the apps to sd thingy still works
    05-03-2014 01:25 PM
  5. ragnand2905's Avatar
    Test the phone with a spare memory card to see if the apps to sd thingy still works
    Yeah. I have been using Sandisk class 4, 8 gb memory card. Working without any problem. I wanted a 16 gb memory card so that I could transfer all my apps to memory card to free up space on phone. But sadly it ain't working on class 10 card.
    05-03-2014 01:33 PM
  6. Sarbuland Yatu's Avatar
    I'm using same SanDisk memory card.....works like charm ....
    05-03-2014 01:36 PM
  7. ragnand2905's Avatar
    I'm using same SanDisk memory card.....works like charm ....
    Lucky you.. Wonder what might be the problem for me.. As of now the class 10 memory card is back to the camera slot. And the class 4 card on my 520!
    05-03-2014 01:39 PM
  8. S Vaibhav's Avatar
    Yeah. I have been using Sandisk class 4, 8 gb memory card. Working without any problem. I wanted a 16 gb memory card so that I could transfer all my apps to memory card to free up space on phone. But sadly it ain't working on class 10 card.
    Ask anybody else(friend, neighbour) having a Lumia to just try the card. If it works, problem is with with phone. If not, the memory card.
    ragnand2905 likes this.
    05-03-2014 01:43 PM
  9. ragnand2905's Avatar
    Ask anybody else(friend, neighbour) having a Lumia to just try the card. If it works, problem is with with phone. If not, the memory card.
    Yeah.. The last resort for me..
    05-03-2014 01:54 PM
  10. ragnand2905's Avatar
    Found out the solution to the problem.
    When the store says can't install the app, restart your phone. When it asks if you want to scan the SD card select no. And bingo you can use all your apps without any problem.. :)
    05-03-2014 03:15 PM
  11. fdalbor's Avatar
    Was the card formated on the phone or another device. Usually they come formated for Fat32 as that is the most popular in use. I have a Sandisk 64GB class 10 in my 820 and it works like a charm. I keep several movies on it to watch during long plane flights. But I also have a 16GM in my backup 520 and its works fine too.
    05-06-2014 01:43 PM
  12. Mitchell Sheehan's Avatar
    Well try using a class 6 card. It should work
    09-29-2014 08:57 AM
  13. ntice_521's Avatar
    I've had no problems with Sandisk class 4 or class 10 cards. Maybe you got a defective card or a counterfeit card.
    10-01-2014 01:48 AM
  14. primuxprimux's Avatar
    Same here ,,san disk ultra ,, 16gb ,, but ni problems bro
    10-03-2014 04:39 AM

Similar Threads

  1. Battery drain on 8.1 preview
    By finbaar in forum Windows Phone 8.1 Preview for Developers
    Replies: 3
    Last Post: 06-04-2014, 01:54 PM
  2. Poor Game Selection on WP8
    By Sanjay Chandra in forum Games
    Replies: 19
    Last Post: 05-04-2014, 12:37 PM
  3. Lumia 520 acting strange
    By Adam Fox2 in forum Windows Phone 8.1 Preview for Developers
    Replies: 1
    Last Post: 05-04-2014, 12:03 AM
  4. Is there a way to turn Internet Sharing on through NFC?
    By Exoma in forum Nokia Lumia 1520
    Replies: 1
    Last Post: 05-03-2014, 12:24 PM
  5. Internet explorer on 8.1 question
    By humblehyper in forum Nokia Lumia 1520
    Replies: 1
    Last Post: 05-03-2014, 11:50 AM
LINK TO POST COPIED TO CLIPBOARD