1. stevemind's Avatar
    Hi team i have a 630 running the last build on windows insider (forgot the build no). I'm on fast build, and it's showing a update ending ........66 , the new build. But it just sticks on waiting to load! The phones charged and plugged in...but nothing happens? I head resetted and tried the WPRT but after plugging my phone into my pc , I get reading my phone, and that's it! I've tried the Lumia recovery tool but still....no joy! Thanks if anybody can give me your advice.
    07-16-2015 02:07 PM
  2. realwarder's Avatar
    I would use the Lumia Recovery Tool to roll back to 8.1 and then upgrade again.

    If that has issues with reverting the phone, then don't connect the phone to the PC. Select the 'phone not detected option'. Connect the phone and long press Power and Volume down until it resets. The app should then be able to connect to and revert the phone to 8.1.

    Note that the latest WM10 upgrade itself takes a LONG time to download if you are upgrading from '66 and shows 0% downloaded for a long while. It doesn't sound like that is your issue though.
    stevemind likes this.
    07-16-2015 02:32 PM

Similar Threads

  1. Dell Venue 8 blocked. I need help, what do I do?
    By i2ils in forum Dell Venue 8 Pro
    Replies: 8
    Last Post: 07-30-2015, 11:50 PM
  2. AT&T 830 upgrade status no longer listed
    By realwarder in forum Nokia Lumia 830
    Replies: 76
    Last Post: 07-29-2015, 11:01 PM
  3. Blitz Brigade connection problems
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 07-16-2015, 03:38 PM
  4. Oculus VR acquires Pebbles Interfaces to help put real hands inside virtual reality
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 07-16-2015, 10:00 AM
  5. Replies: 0
    Last Post: 07-16-2015, 02:13 AM
LINK TO POST COPIED TO CLIPBOARD