1. homegeek's Avatar
    I have been having some issues I think with IE on my 920 and I want to know if it is just me or a limitation of the OS.

    Can someone with the 920 goto the desktop version of Bestbuy.com and see if you are able to navigate through the navigation tabs at the top of the page. I am unable to and it is very frustrating.
    11-12-2012 11:03 PM
  2. downhillrider's Avatar
    are you talking about the Products, Services etc tabs? I pressed on that button and waited for th "open link in new tab" to come up and I was able to get to the drop down menu.
    11-12-2012 11:45 PM
  3. homegeek's Avatar
    are you talking about the Products, Services etc tabs? I pressed on that button and waited for th "open link in new tab" to come up and I was able to get to the drop down menu.
    Exactly! But are you able to actually select something in one of those drop down boxes? Everytime I try the menu disappears as soon as I move my finger and it does not work if I slide it.
    11-12-2012 11:55 PM
  4. KoukiFC3S's Avatar
    This seems to be a common problem with mobile browsers. I think my iPhone did that as well.
    11-13-2012 12:00 AM
  5. homegeek's Avatar
    This seems to be a common problem with mobile browsers. I think my iPhone did that as well.
    I never had an issue like that on Android and I just wondered if this is a limitation of the mobile browser on 8.
    11-13-2012 12:04 AM
  6. theefman's Avatar
    I get the same with my Windows 8 tablet, site probably needs to be updated for IE10.
    11-13-2012 12:07 AM
LINK TO POST COPIED TO CLIPBOARD