1. Dr Floof's Avatar
    I have an unlocked 920, bought in Finland, and I'm using it in the US on at&t. I haven't been able to connect to Twitter, tried different apps including the official Twitter app. I have strong signal & Wifi, OS version 8.0.10211.204. iPhone and GS3 connect perfectly using the same SIM card & Wifi. Have tried soft reset already. When I try to log in the official Twitter client displays: Unable to log in. Failed to validate oauth signature and token. Other Twitter apps display a different message, but none of them can connect. Any ideas?
    04-21-2013 11:04 PM
  2. miodrage's Avatar
    Hmmm, try to log in from ur computer then head to https://twitter.com/settings/devices
    Follow the steps, and I hope this might help.
    04-22-2013 06:20 AM

Similar Threads

  1. Weave error connecting to Twitter
    By Laura Knotek in forum App Spotlight
    Replies: 1
    Last Post: 10-13-2012, 11:24 AM
  2. Cannot connect to the Marketplace
    By Crushing Destroyer in forum Windows Phone 7
    Replies: 0
    Last Post: 09-20-2012, 01:00 PM
  3. Replies: 6
    Last Post: 07-03-2012, 03:04 PM
  4. Replies: 2
    Last Post: 04-17-2012, 10:10 PM
  5. Windows Phone cannot connect to some WiFi networks
    By neiltc13 in forum Windows Phone 7
    Replies: 5
    Last Post: 05-21-2011, 10:25 AM
LINK TO POST COPIED TO CLIPBOARD