1. Christopher Cuppett's Avatar
    Has anybody been able to get internet sharing (aka tethering) working on their 920 with a NET10 (AT&T MVNO) sim card?

    Here's my brief history. I bought an AT&T branded 920 a week ago. This is my first Windows phone (I came from a rooted Android). I am unsure whether it is SIM locked or not because the NET10 SIM card is guaranteed to work on AT&T locked phones and I don't have any other SIM card to test it with. I am assuming it is SIM locked because I bought it off eBay and there was no mention of the phone being unlocked in the auction description.

    I followed the instructions over at forum.xda-developers.com (thread # 2425722) to flash my phone to the latest AT&T Developer ROM (059R2L5, currently Black update). But when I got to the step to enable internet sharing, my experience differed from what was described. There was no "AT&T - LTE 2 - Lumia" option in Access Point, only "AT&T". After installing the Spanish keyboard I still got an error when trying to enable internet sharing that I needed to call AT&T or 611 to enable this feature, which obviously won't work for me because I'm not using AT&T and wouldn't consider paying for this even if I was.

    Other things I tried:
    • Add my NET10 APN profile to Access Point and set it to Active - Still couldn't enable internet sharing
    • Delete AT&T APN from Access Point - Could not do this (no option to delete)
    • Uninstalled Access Point - Still couldn't enable internet sharing
    • Setup my NET10 APN settings after uninstalling Access Point - Still coudn't enable internet sharing
    • Removed SIM card from phone and retried above steps - Still couldn't enable internet sharing


    At this point I am giving up for now. I've already wasted a whole day trying to get this simple feature to work. I had wifi tethering working on my rooted Android phone using the same SIM card, so I know it's possible from a carrier perspective (which seems obvious to me - how could they know about it and block it if the phone OS allows for it?). If anybody has gotten this to work, please let me know what you did. Is it maybe as simple as unlocking my phone, or will that not make a difference?
    08-19-2014 11:43 AM
  2. tgp's Avatar
    I'm not sure, but I think that tethering is very difficult, if not impossible, if you have an AT&T ROM. I have a GoPhone 520 that I flashed with a CV ROM, and tethering works on that. With Android it's much easier to enable tethering due to the open nature of the platform, not to mention the proliferation of tethering apps in the Play Store.
    08-19-2014 11:58 AM
  3. Christopher Cuppett's Avatar
    I'm not sure, but I think that tethering is very difficult, if not impossible, if you have an AT&T ROM...
    I actually don't mind switching to a non-AT&T ROM as long as I can get my NET10 SIM card to work on it. The NET10 SIM card I have is designed to work on the AT&T network, which I why I went with an AT&T ROM. I suppose I could have tried sticking with the Rogers ROM I used to get to the developer ROM, but from what I was reading the developer ROM would allow for tethering so I never bothered to test my data and MMS settings on the Rogers why it was on there. Can somebody confirm that this would work before I waste more time on this project? I'm starting to hate having to start from scratch setting my phone up every day. I've done it three times since I got my phone last week.
    08-19-2014 01:04 PM
  4. ssapre's Avatar
    I actually don't mind switching to a non-AT&T ROM as long as I can get my NET10 SIM card to work on it. The NET10 SIM card I have is designed to work on the AT&T network, which I why I went with an AT&T ROM. I suppose I could have tried sticking with the Rogers ROM I used to get to the developer ROM, but from what I was reading the developer ROM would allow for tethering so I never bothered to test my data and MMS settings on the Rogers why it was on there. Can somebody confirm that this would work before I waste more time on this project? I'm starting to hate having to start from scratch setting my phone up every day. I've done it three times since I got my phone last week.
    1- your Net10 sim card is designed to work with AT&T network, not 'with AT&T ROM / softwares'.
    2-Network sharing is blocked by AT&T in most of its devices. If you see forum, you will see same cases.
    3 - There are ppl (including me) who are able to get the internet sharing working when you flash Rogers or any other ROMs on the phone. so you can may be give it a try.
    08-19-2014 01:42 PM
  5. Christopher Cuppett's Avatar
    1- your Net10 sim card is designed to work with AT&T network, not 'with AT&T ROM / softwares'.
    This confuses me a bit because it appears that a lot of the ROMs are SIM locked. I assume that any ROM that is SIM locked and is not an AT&T ROM would not work. I wasn't sure which ROM to go with for use in the USA, but I did see people recommend the developer ROM, so that is what I went with.

    2-Network sharing is blocked by AT&T in most of its devices. If you see forum, you will see same cases.
    I have looked in this forum and on xda-developers forum, and I kept seeing people say that they had success getting their Nokia Lumia 920s tethering with the AT&T Developer ROM. The Spanish keyboard trick apparently works for a lot of people, but it either doesn't work anymore on newer updates or only works for AT&T and not AT&T MVNOs.

    3 - There are ppl (including me) who are able to get the internet sharing working when you flash Rogers or any other ROMs on the phone. so you can may be give it a try.
    I'd give it another try if I thought I would have a good chance of getting it to work. Can you describe what product code you used? Was it 059Q6W4 Rogers? Which ROM would you recommend? Does it matter which ROM you use?

    Also, with the ROM you have, did you have to do anything special to get the Internet Sharing to work, like install a different keyboard? If so, can you please describe what you did to get it to work?
    08-19-2014 03:31 PM
  6. yipsan's Avatar
    Many people were successful in having att unlocked phones working, but cyan update seems to be breaking that.

    I have an att 1020, unlocked, was running great on 8.0 and black. Once I updated to 8.1 and cyan, cannot get internet sharing to work on airvoice sim (att mvno), but can get it to work on lycamobile (tmo mvno). Search 920 internet sharing here and a great thread about getting internet sharing working, but again, cyan seems to be wrecking it.
    08-20-2014 10:51 AM

Similar Threads

  1. Replies: 18
    Last Post: 11-11-2015, 08:51 AM
  2. Internet connection slows down
    By DrSARANG MALI in forum Ask a Question
    Replies: 2
    Last Post: 08-19-2014, 08:19 AM
  3. Replies: 2
    Last Post: 08-19-2014, 05:34 AM
  4. Internet Download manager For WP 8.1????
    By Brokn Wing in forum Ask a Question
    Replies: 1
    Last Post: 08-19-2014, 04:35 AM
  5. Custom Windows OS coming to Intel Galileo to power Internet of Things
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 08-18-2014, 04:30 PM
LINK TO POST COPIED TO CLIPBOARD