1. resle's Avatar
    Hi,

    I got a verizon Lumia Icon from the US. However I live in China.
    Everything works flawlessy, except for the fact that Internet Explorer & Email don't seem to work over 3G/HDSPA. Yet, other apps that need to connect to internet, work just fine (if, perhaps, a bit slowly).

    Any hint?
    Thanks

    a.
    03-31-2014 12:36 AM
  2. Himanshu Chowdhary's Avatar
    if you are unable to connect to 3G , probably chances are you must be using 2G internet which is very slow , try to use Wi-Fi :)
    03-31-2014 12:58 AM
  3. resle's Avatar
    if you are unable to connect to 3G , probably chances are you must be using 2G internet which is very slow , try to use Wi-Fi :)
    Ehm, no - the icon on top clearly says "H" or "H+" , going all the way back to "E" only very rarely. So it connects, and it connects to HDSPA. And it works. And only Internet Explorer and Email don't work properly, everything else does.
    03-31-2014 01:16 AM
  4. Himanshu Chowdhary's Avatar
    Ehm, no - the icon on top clearly says "H" or "H+" , going all the way back to "E" only very rarely. So it connects, and it connects to HDSPA. And it works. And only Internet Explorer and Email don't work properly, everything else does.
    try to do a soft reset :)
    03-31-2014 01:24 AM

Similar Threads

  1. Lumia 1020 Video audio snap crackle pop
    By textomatic in forum Nokia Lumia 1020
    Replies: 2
    Last Post: 08-16-2014, 11:39 AM
  2. Lumia 820 memory query
    By aswinbarathb in forum Nokia Lumia 820
    Replies: 6
    Last Post: 04-07-2014, 01:25 PM
  3. Getting a Lumia 1520
    By george_520 in forum Nokia Lumia 1520
    Replies: 4
    Last Post: 03-31-2014, 01:08 PM
  4. Replies: 3
    Last Post: 03-30-2014, 04:51 PM
  5. How's your battery on the Lumia 925?
    By shykhan16 in forum Nokia Lumia 925
    Replies: 1
    Last Post: 03-30-2014, 01:38 PM
LINK TO POST COPIED TO CLIPBOARD