1. rpcortazar's Avatar
    I have LTE signal ,becouse no display in bar signal
    Carrier Telcel MX Gsm
    06-15-2014 11:28 AM
  2. Corepc's Avatar
    Does it say 4G?
    What about download speeds?
    06-15-2014 01:02 PM
  3. rpcortazar's Avatar
    Yes 4g lte, download 30 mb, upload 25 mb.
    06-15-2014 01:15 PM
  4. gernerttl's Avatar
    Wow! That is a whole lot faster than I'm getting on Verizon here in Hawaii. Maybe I should move to Mexico if I want fast LTE speeds. :-D
    rpcortazar likes this.
    06-15-2014 04:00 PM
  5. rpcortazar's Avatar
    Send Pic's.
    shows that no signal and the signal type, in this case LTE.
    Thank you.
    Attached Thumbnails wp_ss_20140615_0001-1.jpg   wp_ss_20140617_0001.jpg  
    06-17-2014 09:51 AM
  6. gernerttl's Avatar
    Evidently, that is a problem if you are using a non-Verizon SIM card in the Icon. There are a couple other threads about using the Icon on non-Verizon LTE networks, specifically T-Mobile. I wouldn't worry too much as long as you're getting good data speeds.
    06-17-2014 01:30 PM

Similar Threads

  1. Lumia 1520.3 on T-Mobile Weak Cell Signal
    By matrixcaptain84 in forum Nokia Lumia 1520
    Replies: 18
    Last Post: 01-24-2016, 01:09 PM
  2. No active network found: HTC 8x
    By WPCentral Question in forum Ask a Question
    Replies: 7
    Last Post: 11-02-2014, 09:24 AM
  3. No notifications on Glance
    By Draganta in forum Windows Phone 8.1 Preview for Developers
    Replies: 2
    Last Post: 06-18-2014, 05:08 AM
  4. htc 8s no settings after 8.1 developer upgrade
    By WPCentral Question in forum Ask a Question
    Replies: 2
    Last Post: 06-15-2014, 07:27 PM
LINK TO POST COPIED TO CLIPBOARD