1. Roy98's Avatar
    At first when I added my Microsoft account on the phone, it imported all my contacts into the People app. But later I have added new contacts in the account on Outlook.com using my PC and I cannot find a way to get those new contacts to appear on the phone.

    I have left the phone fully connected for 2 days now and it kept checking all new e-mails from the account, but does nothing with the contacts. But if I check my account on Outlook.com from a computer I can see the new contacts correctly.

    I went to Settings and synced the account several times but it does not appear to do anything with the contacts. However, if I add a new contact from the phone, it will instantly appear on my account on Outlook!
    04-19-2013 12:14 PM
  2. WavingReds's Avatar
    Just edit it in Outlook.com

    This bug happens now and then >.>

    i.e.

    Remove number from the contact and save then add it again save it should now appear after you sync. If that doesn't work then it's a big bug from MS
    04-19-2013 02:24 PM
  3. rimlover's Avatar
    At first when I added my Microsoft account on the phone, it imported all my contacts into the People app. But later I have added new contacts in the account on Outlook.com using my PC and I cannot find a way to get those new contacts to appear on the phone.

    I have left the phone fully connected for 2 days now and it kept checking all new e-mails from the account, but does nothing with the contacts. But if I check my account on Outlook.com from a computer I can see the new contacts correctly.

    I went to Settings and synced the account several times but it does not appear to do anything with the contacts. However, if I add a new contact from the phone, it will instantly appear on my account on Outlook!
    in settings do you have the 'contacts' check box? i had the same issue but when i went to setting of my microsoft account (which is my primary email & contact address), the 'contacts' wasn't there. it could only sync mail. when i added the same address as a new account it works. i decided to do a software reset and got my phone bricked and now it's getting fixed at nokia repair centre.
    04-19-2013 03:00 PM
  4. rimlover's Avatar
    Just edit it in Outlook.com

    This bug happens now and then >.>

    i.e.

    Remove number from the contact and save then add it again save it should now appear after you sync. If that doesn't work then it's a big bug from MS
    mine didn't have contacts in the settings. ended up resetting my phone, got bricked and now it's in repair.
    04-19-2013 03:00 PM
  5. eric12341's Avatar
    Might be due to the recent background changes within outlook to allow aliases and the like. Should probably be resolved in a week or two.
    AngryNil likes this.
    04-19-2013 05:18 PM
  6. Roy98's Avatar
    Just edit it in Outlook.com

    This bug happens now and then >.>

    i.e.

    Remove number from the contact and save then add it again save it should now appear after you sync. If that doesn't work then it's a big bug from MS
    I considered removing contacts from my account and adding them back again to re-sync too, but found that on Outlook.com there is no option to remove all the contacts at one, only have to select them to delete one by one so it is too complicated...

    in settings do you have the 'contacts' check box? i had the same issue but when i went to setting of my microsoft account (which is my primary email & contact address), the 'contacts' wasn't there. it could only sync mail. when i added the same address as a new account it works. i decided to do a software reset and got my phone bricked and now it's getting fixed at nokia repair centre.
    Under the phone settings for my Microsoft account there is indeed only 1 checkbox for E-mails, no Contacts. So I tried adding the same account again (it'd appear as Hotmail 2) and this time there're checkboxes for Contacts (plus Calendar too). But even with this double account I still can't get the phone to sync to contacts at all!

    So finally I found a solution. I created a new Google account and imported my contacts there, and then add that Google account to the phone and set it to sync only the contacts. Now, all the contacts are perfectly and promptly synced to my phone right away. It solved the problem for now but I guess this means Microsoft's system is really problematic...
    04-20-2013 03:51 AM
  7. rimlover's Avatar
    I considered removing contacts from my account and adding them back again to re-sync too, but found that on Outlook.com there is no option to remove all the contacts at one, only have to select them to delete one by one so it is too complicated...

    i'm glad you found a solution. see for me when i added the same email address as the microsoft account i got the calendar and contact check boxes. i just wanted it to be more 'clean' and not have excess accounts for no reason so i decided to reset the phone. i guess i should have just kept the 2 accounts because i don't even have the phone haha.

    Under the phone settings for my Microsoft account there is indeed only 1 checkbox for E-mails, no Contacts. So I tried adding the same account again (it'd appear as Hotmail 2) and this time there're checkboxes for Contacts (plus Calendar too). But even with this double account I still can't get the phone to sync to contacts at all!

    So finally I found a solution. I created a new Google account and imported my contacts there, and then add that Google account to the phone and set it to sync only the contacts. Now, all the contacts are perfectly and promptly synced to my phone right away. It solved the problem for now but I guess this means Microsoft's system is really problematic...
    i'm glad it worked out for you. when i did it, i just added the same email address as my microsoft account and it was there. i just didn't want to have 2 of the same account so i decided to reset it. probably should have just kept 2 accounts then get it bricked and send it for repair. i'm glad it worked for you though.
    04-20-2013 08:27 PM

Similar Threads

  1. Can't sync contacts from microsoft account on Lumia 720
    By AlexanderPD in forum Other Operating Systems
    Replies: 4
    Last Post: 05-22-2013, 06:14 PM
  2. Photos no longer syncing from my phone to my laptop
    By Ashley Goldsmith in forum Windows Central Archive
    Replies: 3
    Last Post: 04-09-2013, 08:34 PM
  3. AT&T no longer able to order Lumia 920's from Nokia
    By slavrenz in forum Windows Phones
    Replies: 46
    Last Post: 12-26-2012, 01:25 PM
  4. Arrive no longer connects to my WiFi.
    By IamDefiler in forum Other Operating Systems
    Replies: 8
    Last Post: 12-15-2011, 11:35 AM
  5. No longer able to sync my phone with Zune. Any fixes/alternatives?
    By mattschwabby in forum Other Operating Systems
    Replies: 7
    Last Post: 12-11-2011, 08:41 AM
LINK TO POST COPIED TO CLIPBOARD