1. Saurabh Vatsa's Avatar
    I am having this Lumia 620 and facing this weird problem for a while.... My touch screen responses weird sometimes..... sometimes it becomes unresponsive, sometimes buttons press itself without my tap and sometimes back button gets on hold(long press) when i tap it .... I have to lock and unlock screen to make it work again.....
    Now i don't know the reason behind this but this happens when my hands are a little moist( a bit sweaty)... or i think this may b due to screen guard as it is getting a bit off from sides..... I tried hard reset and soft also but this did not solved the problem..... Do anyone facing the problem with their lumia??
    10-28-2013 10:56 AM
  2. BrandonTeoh's Avatar
    I do have the same problem, but on another device. My HTC Radar start acting up the same way you did even recorded a video about it.


    Judging from the responses, it could be a hardware issue, but I need more investigation.
    10-28-2013 11:11 AM
  3. Saurabh Vatsa's Avatar
    hmm... i just saw ur video... mine does not completely gets unresponsive but it responses like when u put one finger on screen and try to operate phone with another finger and then the touch lags..... same is the prob with mine... it feels like there is already a tap on any part of screen... Now i don't know how to explain this to nokia care as this problem happens only sometimes... :(
    10-28-2013 11:46 AM
  4. teckris's Avatar
    hmm... i just saw ur video... mine does not completely gets unresponsive but it responses like when u put one finger on screen and try to operate phone with another finger and then the touch lags..... same is the prob with mine... it feels like there is already a tap on any part of screen... Now i don't know how to explain this to nokia care as this problem happens only sometimes... :(
    I too get the same bug. Hope it has to do with two things.
    1) swet or water on screen
    2) disturbances to Proximity sensors.

    I had this bug even on the Clean screen. may be the screenguard I used is causing the problem. Do you have Screen Guard?
    10-28-2013 12:13 PM
  5. Saurabh Vatsa's Avatar
    I too get the same bug. Hope it has to do with two things.
    1) swet or water on screen
    2) disturbances to Proximity sensors.

    I had this bug even on the Clean screen. may be the screenguard I used is causing the problem. Do you have Screen Guard?
    yes... I do have a screen guard and also it is coming off from one side.. But it is not covering proximity sensor.... :/
    10-28-2013 12:25 PM
  6. teckris's Avatar
    yes... I do have a screen guard and also it is coming off from one side.. But it is not covering proximity sensor.... :/
    i dont mean the screen guard is covering proximity sensor. it could be dust or oil. just hope this bug is software related as it functions smoothly after unlocking once.
    10-28-2013 09:18 PM
  7. Saurabh Vatsa's Avatar
    i dont mean the screen guard is covering proximity sensor. it could be dust or oil. just hope this bug is software related as it functions smoothly after unlocking once.
    ya.. I also hope so... Coz mine also starts working after unlocking again... I think it is due to my screen guard... I'll try a new one...
    10-28-2013 09:56 PM
  8. eroselim's Avatar
    I am also using L620, without Screen Guard but still got the problem. And the only resolve is to Lock Unlock the phone to make it responsive again. I don't know what's supposed to be the problem but I think it is a screen issue for all L620.
    11-03-2013 11:43 PM
  9. Saurabh Vatsa's Avatar
    I am also using L620, without Screen Guard but still got the problem. And the only resolve is to Lock Unlock the phone to make it responsive again. I don't know what's supposed to be the problem but I think it is a screen issue for all L620.
    i recently installed a new screen guard on 620... Now its working fine... Problem persists when i try to use it with my sweaty hands... Rest it acts normal now... Fingers crossed :D
    11-04-2013 05:37 AM
  10. teckris's Avatar
    I have put my phone Touch sensitivity to normal from High.. now its working more smooth :P
    post about Yours now..
    11-04-2013 09:46 AM
  11. Saurabh Vatsa's Avatar
    I have put my phone Touch sensitivity to normal from High.. now its working more smooth :P
    post about Yours now..
    lol... I never put that on high sensitivity... It was acting abnormal on normal mode only.. :D
    Bt now its ok... I think that was the problem with my old screen guard.. :)
    11-06-2013 10:34 PM
  12. teckris's Avatar
    lol... I never put that on high sensitivity... It was acting abnormal on normal mode only.. :D
    Bt now its ok... I think that was the problem with my old screen guard.. :)
    Ah so I too will change mine :)
    11-07-2013 04:28 AM
  13. eroselim's Avatar
    lol... I never put that on high sensitivity... It was acting abnormal on normal mode only.. :D
    Bt now its ok... I think that was the problem with my old screen guard.. :)
    Does your problem still persists after changing your screen guard? :)
    12-04-2013 08:49 PM
  14. Saurabh Vatsa's Avatar
    Does your problem still persists after changing your screen guard? :)
    nope.. It still persists.. Bt is very rare now... Happens a lot when my hands r sweaty.. :|
    12-21-2013 03:22 AM
  15. tonymathewt's Avatar
    Initially I thought that this is due to some static electricity issue but 2 others with the same model(Lumia 520) in my office are not having any issue.
    Then I suspected my n/w or SIM card but the problem is still there even without a SIM card!
    Now I suspect the s/w version in my phone it is not having Lumia update like others in my office and the OS version is 8.0.10211.204 both are old compared to my colleague's phones.
    03-10-2014 08:55 AM
  16. unnatixlr8's Avatar
    It happens with me. When it does, I just press lock button and unlock it. It fixes the problem quickly.
    03-10-2014 09:20 AM
  17. tonymathewt's Avatar
    It happens with me. When it does, I just press lock button and unlock it. It fixes the problem quickly.
    This does not work in my case. One thing I noticed is this issue happens if the phone is kept idle for a while(around 1 hour). Local Nokia care guys does not guarantee a time to get my device fixed if I want to replace the touch screen. There are people who have left their device for more than a month!
    03-14-2014 08:12 AM

Similar Threads

  1. No built in countdown Timer?
    By Terrorizer in forum Windows Central Archive
    Replies: 5
    Last Post: 03-19-2014, 08:14 AM
  2. QuickTime in IE11 on SP2
    By cre8tivspirit in forum Microsoft Surface Pro
    Replies: 10
    Last Post: 12-10-2013, 03:16 PM
  3. any one knows what features will be there for lumia 520.. ?
    By Mohammad Faisal in forum Windows Phones
    Replies: 6
    Last Post: 10-29-2013, 12:20 AM
  4. Best way to test my battery?
    By Raghav94 in forum Windows Phones
    Replies: 3
    Last Post: 10-28-2013, 06:08 PM
  5. iPhones hit with Daylight Savings Bug again, this time in iOS 7
    By hagjohn in forum Microsoft News & Rumors
    Replies: 2
    Last Post: 10-28-2013, 09:51 AM
LINK TO POST COPIED TO CLIPBOARD