1. MikeSo's Avatar
    When I use the Citi bookmark I had, https://mobile.citibankonline.com/mobile/thin , it gives me the "We're having trouble displaying this page" error. It seems to bounce back and forth between different sites before the error comes up. I never had an error before IE11, but I haven't used the site for a few days either.

    Can anyone else connect to the site, and if you have a credit card with them can you login? Since they don't have a WP app, it would be quite the problem if not even their website works.
    04-14-2014 11:52 PM
  2. kyriacou48's Avatar
    When I use the Citi bookmark I had, https://mobile.citibankonline.com/mobile/thin , it gives me the "We're having trouble displaying this page" error. It seems to bounce back and forth between different sites before the error comes up. I never had an error before IE11, but I haven't used the site for a few days either.

    Can anyone else connect to the site, and if you have a credit card with them can you login? Since they don't have a WP app, it would be quite the problem if not even their website works.
    Hey Mike, just tested for you and have the same issues as you.

    Decided to try this way instead - can you give this a shot?

    https://online.citibank.com/US/Welcome.c

    hope this helps :)
    04-14-2014 11:57 PM
  3. MikeSo's Avatar
    Thanks for the suggestion. When I try that, it takes me to a login page, but then the same thing happens after that as I described in the OP. I appreciate you giving it a shot though. I wonder if it was something in IE11 that broke it, or if it's something in their side that it acting up tonight.
    04-15-2014 12:22 AM
  4. ThermoDust's Avatar
    Goto citibankonline.com and it will redirect you. I just tested it twice and it worked fine for me. Granted, Citibank!, I like it more if you would make an App... I hope they read this.
    04-15-2014 12:33 AM
  5. MikeSo's Avatar
    Goto citibankonline.com and it will redirect you. I just tested it twice and it worked fine for me. Granted, Citibank!, I like it more if you would make an App... I hope they read this.
    I can get to the login page using that site, but I get the error described above when I try to log in. Are you able to not only go to the login page, but actually log in as well?
    04-15-2014 12:35 AM
  6. MikeSo's Avatar
    Well, anyone that sees this that has a Citi credit card and can see if this works for them? I suspect it's an issue with IE11. It has never behaved like this before. But before I contact Citi it would be great to know.
    04-15-2014 11:04 AM
  7. MikeSo's Avatar
    Bumping this one more time... I no longer get an error message, but I end up in a loop that just takes me to a page with information and an icon to go to a login page... But when I click it, it just reloads the same page again. Anyone?
    04-17-2014 01:04 AM

Similar Threads

  1. IE11 showing only "mobile version"
    By akks in forum Other Operating Systems
    Replies: 31
    Last Post: 06-09-2015, 07:25 AM
  2. WP 8.1 in Luma 525
    By Suren2306 in forum Other Operating Systems
    Replies: 1
    Last Post: 04-15-2014, 09:43 AM
  3. Cortana not connecting to Facebook
    By riyaz ahamed99 in forum Windows 10
    Replies: 4
    Last Post: 04-15-2014, 12:52 AM
  4. Putting Nokia Sound/Video to the test: Live in Concert
    By themadpoet1 in forum Windows Phones
    Replies: 1
    Last Post: 04-14-2014, 11:45 PM
  5. "No cloud streaming" in 8.1
    By tribexx in forum Other Operating Systems
    Replies: 1
    Last Post: 04-14-2014, 11:29 PM
LINK TO POST COPIED TO CLIPBOARD