1. PalZer0's Avatar
    Over the last couple of days, I've been seeing "Network error" popups when attempting to load the app when my phone (Lumia 1020) is connected to my home Wi-Fi.

    When my phone is connected to my mobile network, the app behaves normally. I can also load the mobile site when connected to Wi-Fi.

    I can't share a screenshot at the moment but the error is "Could not connect to Windows Central. An exception occurred during a WebClient request.".
    06-08-2015 05:02 AM
  2. aximtreo's Avatar
    I would try resetting your router and see if that helps. Sounds like your Wi Fi isn't performing correctly for some reason and sometimes a reset will help.

    I would also reset your device and see if that helps as well.

    Let us know if this doesn't work for you.
    06-08-2015 10:08 AM
  3. PalZer0's Avatar
    I did try rebooting my phone but that didn't resolve anything. Also, it's only the Windows Central app that's misbehaving when connected to Wi-Fi as every other app - even Tapatalk (which I'm using to post this) - works fine when connected to Wi-Fi.
    06-08-2015 07:30 PM
  4. pmhgeneral's Avatar
    I had the same problems as you, I got back into the app than open in browser and signed out, them closed the app, open back up than open browser and signed back in this worked for me.
    06-08-2015 08:10 PM
  5. PalZer0's Avatar
    Seems to be working properly now. I'd say that something needed kicking on the backend.
    Laura Knotek likes this.
    06-09-2015 01:43 AM

Similar Threads

  1. Friend's 920 - SIM ERROR
    By X0LARIUM in forum Windows Phones
    Replies: 5
    Last Post: 09-09-2015, 10:40 AM
  2. Facebook Messenger getting stuck on Lumia 930
    By tehaer in forum General Phone Discussion
    Replies: 4
    Last Post: 06-20-2015, 08:11 AM
  3. **Windows central error**
    By djeire84 in forum Site Feedback & Help
    Replies: 5
    Last Post: 06-12-2015, 08:45 PM
  4. Screen stays dark after call and when alarm goes off
    By crummel in forum Windows Phones
    Replies: 0
    Last Post: 06-08-2015, 03:21 AM
LINK TO POST COPIED TO CLIPBOARD