1020/Cyan/ upgrade to 8.1.1?

LumiaTibs

New member
Sep 19, 2014
9
0
0
Visit site
Hi all

I can't wait for Cortana any longer.

I've got a 1020 running Cyan firmware, and my main uses for the phone are obviously calls and texts, along with social media in fb, Twitter and Insta, music, and photography.

I am thinking of upgrading via DP, but wanted to know (searched but difficult to come to a conclusion), is 8.1.1 stable enough for everyday use?

Thanks
 

jordanzhninja

New member
May 4, 2014
177
0
0
Visit site
8.1.1 on Black was stable for me on a 520, so I don't see why 8.1.1 wouldn't be stable on a cyan 1020.

However if you are unsure, ask someone with a 1020 who has upgraded to 8.1.1.
 

LumiaTibs

New member
Sep 19, 2014
9
0
0
Visit site
This may sound silly, but if I download it, can I then just update to the upcoming commercial release of denim, or is a restore to wp8.1 needed?
 

PepperdotNet

New member
Jan 6, 2014
1,809
0
0
Visit site
I've been running DP since day one and would never go back. it works. And I expect Denim will be just another update.

1020 RM-877 nam att on Cyan
 

TuanLVT

New member
Dec 3, 2013
43
0
0
Visit site
ive used WP8.1.1 DP on my Nokia Lumia 1020 with Cyan update and im from Finland and no problem seen... wont be going back to 8.1
 

Michael Flynn4

New member
Oct 31, 2014
1
0
0
Visit site
Hi

I was on 8.1 DP on my 1020 prior to the roll out of Lumia Cyan. I rolled back and updated to Cyan because at the time 8.1 DP didn't support BLE / Bluetooth 4.0 so I couldn't use my treasure tags, bluetooth head set etc. My phone is originally from Taiwan and the network updates are pushed out by the original network provider in the origin region and not whatever network you are current using, in whatever region you are currently in, regardless of the phone being unlocked.

So I am stuck on the current software version available in Taiwan which is 3051.50009.1424.0001

I have searched for the answer and come up empty. (Maybe that means the question is completely absurdly obvious?)

Can someone tell me if the latest version of DP supports BLE and works with all NFC accessories?

I don't want to go through the whole install and update of DP again only to find BLE unsupported and having to roll back to Cyan?

Help much appreciated.

Michael

1020 / Vodafone / Ireland
 

Members online

Forum statistics

Threads
322,560
Messages
2,242,260
Members
427,955
Latest member
gorly3