950 XL Call Quality Problem - NEED HELP!

Narun

New member
Dec 16, 2012
23
0
0
Visit site
Hi all,

I've recently got my L950XL after 2 years WP sabbatical. It feels great coming home. However, my handset has one major issue - everyone at another end of the call complains that they could barely hear me and I tried to listen to myself - the call is very choppy, very low in volume, and not clear at all. I am trying to locate the problem - whether it is a hardware, or software issue. I really wish this is a software problem since I don't want to send it to Microsoft's repair people due to mixed experiences I've read online and that I won't have any phone to use in the meantime.

Here is what I've done so far:
The problem first arose when I'm on the anniversary update. I hard reset the phone three times. Nothing happened. I then run the recovery tool in order to flash the older OS (the one before the Anniversary Update) and the problem still persists but marginally better according to some people I tried to call. I then came back on AU - nothing changed. So I decided to jump on the pre-release OS build (14393.105). Again doesn't seem to improve the situation. And that's where I am right now.

I seriously don't want to send the phone in for warranty repair. I am quite comfortable doing some complex software stuff if that's what it takes. Has anyone had this kind of experience? How did you solve it? Is warranty repair the only choice I have? How long does it take and is it any good?

I would appreciate any comments/suggestions you may proffer.

Cheers,
 

Narun

New member
Dec 16, 2012
23
0
0
Visit site
One additional info - if I make a call through social media apps such as LINE or even Skype, the problem is noticeably less severe. So I make a wild guess that this is a software bug rather than a hardware issue.

Any thoughts?
 

Narun

New member
Dec 16, 2012
23
0
0
Visit site
I think I owe it to myself to share how I eventually resolved the issue. I basically gave up and went to the Microsoft Store on Fifth Avenue in New York City to see what they could do for me. I explained the problem, demonstrated the issue to them. I mean it's not hard to see why the phone had serious issues just by having a phone conversation with me. The staff decided to swap me a new (read refurbished) one they have in stock. It's been one night and I have not had a problem with the new unit.

I have learned a few things out of this turbulent re-entering into the W10M scene. Firstly, the silence in this forum and also Microsoft Support Community spoke volume of this problem. I still believe that this is a software glitch rather than hardware but I might be wrong. I know it doesn't affect a lot of people including the new unit I received (so far at least). This means Microsoft has a problem maintaining quality control in manufacturing hardware units. This is not the first time I have problems with MSFT products. I also have to swapped my Surface Pro 3 before I received the one that works (admittedly once it works, it's just perfect. SP3 is probably one of the best tech investments I have made).

I hope I can now enjoy a stable Lumia from now on. When it's issue-free, it's my most favourite mobile device bar none. I was on iOS during my two year sabbatical - it's like be with the right girl but not the girl you love. Everything went smoothly, I could get all apps I want, the OS was very extremely stable. But it's cold, it's a functional device. Now I'm back to my passion. I hope I will have a wonderful few years going forwards. Thank you everyone who is following my story so far.
 

Joe920

Active member
Nov 13, 2012
1,677
0
36
Visit site
Last year people were having call quality issues when "hey Cortana" was enabled, but I think they fixed that since. Maybe you were on an old firmware version that still had this bug. That issue generated more like an echo though, so maybe your problem was different.
 

Members online

No members online now.

Forum statistics

Threads
324,179
Messages
2,245,105
Members
428,172
Latest member
Christinaenth