Battery Draining Quickly on 1020

Status
Not open for further replies.

drtek

New member
May 15, 2013
457
0
0
Visit site
With most of the background tasks off, the battery barely lasts 12 hours. Any suggestions on how to remedy the situation?
 

LastBattle

New member
May 26, 2012
234
0
0
Visit site
Its not a matter of having background task on or not already. I'm getting some horrible standby time. The phone doesn't want to connect to G/Edge when possible. Its always on 3G/HSPA+, unlike variants that are non AT&T which is the exact opposite to save power consumption..

I have a 925 and 1020, both with the same email sync, background task, glance screen on and other settings.

My phone is left idle from 12am to 8am this morning..

Lumia 1020 [AT&T on Singtel Network]:
85% to 46% = 4.8% / hr
y22a.png


Lumia 925 [Singapore country variant]
65% to 50% = 1.8% / hr
fhm5.png



Anyone managed to solve this?
 

prakashdg

New member
Aug 13, 2013
15
0
0
Visit site
change sync setting for email accounts, maybe 15 mins for the most important one and 30 minutes to an hour for the rest...

how many charges has the battery gone through..if only 4 or 5, it might take some time to perform optimally....let the battery get rellay low (even maybe till the poitn it turns off) and then charge it fully for the first couple of times ..it worked for me, so I think it should work for u also.
 

LastBattle

New member
May 26, 2012
234
0
0
Visit site
change sync setting for email accounts, maybe 15 mins for the most important one and 30 minutes to an hour for the rest...

how many charges has the battery gone through..if only 4 or 5, it might take some time to perform optimally....let the battery get rellay low (even maybe till the poitn it turns off) and then charge it fully for the first couple of times ..it worked for me, so I think it should work for u also.

I'm on at least the 20th charge cycle now with email sync setting set to daily.
Its still draining 4~5% in idle right now btw...
 

tgr42

New member
Jul 31, 2012
286
0
0
Visit site
Still getting great battery life here. LTE, wi-fi always connected, 2 email accounts set to check every 15 minutes, double-tap to wake. Everything else disabled. Only background tasks are Battery Sense and Weather Wallpaper. I suggest disabling everything and then powering the phone off and on. If you still get major battery drain, leave the phone in airplane mode for a while and see if that makes a difference. If not, you know it's not cellular-related.
 

Attachments

  • battery.png
    battery.png
    68.2 KB · Views: 4

LastBattle

New member
May 26, 2012
234
0
0
Visit site
Something is sipping power on this AT&T variant of 1020 :( I've my phone set to airplane mode since 3AM - 12 PM..
Despite that its still 4.1% / hour
1r3.png

===
On Lumia 925 (SG Country variant), its 1% / hour with WiFi.
 

LastBattle

New member
May 26, 2012
234
0
0
Visit site
0e0u.jpg


5 minutes of Fiddler... my email setting is set to 'daily' :s11::eek:
It seems to be connecting to login.live.com every 1 minute with the server not replying..


---------------------


Something else that's interesting:

GET
Code:
https://developerservices.windowsphone.com/Services/WindowsPhoneRegistration.svc/01/2010/DeviceStatus?deviceId=XXXX&fullDeviceId=XXXX HTTP/1.1
Host: developerservices.windowsphone.com

HTTP/1.1 200 OK
Code:
Cache-Control: private
Content-Length: 437
Content-Type: application/xml; charset=utf-8
Server: Microsoft-IIS/8.0
X-WP-Activity-ID: XXXXXXX
X-WP-Served-By: DeviceRegistrationService_IN_0
X-AspNet-Version: 4.0.30319
X-Powered-By: ASP.NET
Date: Thu, 22 Aug 2013 06:31:09 GMT
<ResponseOfRegisteredDeviceStatus xmlns="Microsoft.WindowsMobile.Service.Marketplace" xmlns:i="[URL]http://www.w3.org/2001/XMLSchema-instance[/URL]">
   <ResponseCode>0x00000000</ResponseCode>
   <ResponseMessage i:nil="true"/>
       <Entity xmlns:a="[URL]http://schemas.datacontract.org/2004/07/Microsoft.WindowsMobile.Service.Marketplace.BLLDevPortal.Entities[/URL]">
           [B]<a:DaysLeft>714</a:DaysLeft>
           <a:AppsAllowed>10</a:AppsAllowed>[/B]                
       </Entity>
   </ResponseOfRegisteredDeviceStatus>
 

tgr42

New member
Jul 31, 2012
286
0
0
Visit site
Your screenshots show the little dot within a circle icon that means that something is currently accessing your location. That should not be happening too often - if it is, it will drain your battery. Go to Settings, Location and turn off location services. See if that makes a difference.
 

LastBattle

New member
May 26, 2012
234
0
0
Visit site
idle time now:
77p.png


n0w0.png


toqy.png


I've no idea what happened. Ever since I removed my SIM card from 1020 that day to test run the battery on the 925. It got better magically after plugging that SIM card back in...
 
Status
Not open for further replies.

Members online

No members online now.

Forum statistics

Threads
323,208
Messages
2,243,460
Members
428,046
Latest member
shadow1412