Cannot find GPS when using data connection

RonV42

Member
Jun 8, 2011
113
0
16
Visit site
In the last two days on my T-Mobile 925 I have turned on Waze or Nokia maps when leaving the home. I end up with a message in Waze that it's searching for the GPS signal. If I launch GPS info it states it's using aGPS (assisted GPS), and that the GPS is started but I should move to open sky. I can leave it in this state for my entire commute of a hour it will never lock into a GPS signal.

Now going on a hunch that T-Mobile or Microsoft is the issue here I put the phone into flight mode which will turn off data (Wifi, cell, etc) and then I launched the GPS info and it magically got a GPS signal and locked on. Launched Here Drive and it locked in and was able to track my commute just fine. I turned on the data connections while it was running Here Maps and it kept GPS tracking just fine. It also worked fine on the way home from work without fiddling with flight mode.

Again tonight in my driveway I fired up and has the same darn GPS experience and the flight mode trick was the only thing that let the GPS lock in again. I tried calling T-Mobile and they only responded with a factory reset of the phone. Even though I walked them though how to get it to work. I think they have an aGPS data issue causing the location services in the phone to malfunction.

Has anyone else had these types of issues? I do remember that AT&T used to munge up their cell tower addresses once a year throwing people phone locations into the middle of some unknown town forcing a cold start to the GPS until Google updated their aGPS data. Is there a way to get T-Mobile to look into this or am I stuck fiddling around with radios on the phone to make it work?
 

Members online

No members online now.

Forum statistics

Threads
324,170
Messages
2,245,090
Members
428,173
Latest member
Christinaenth