Edge freezing (webpage not responding) since the last cumulative update

badelhas

New member
Dec 17, 2015
354
0
0
Visit site
After the anniversary update there were a couple of cumulative updates and now Edge is freezing a lot ("want to recover webpage? " warning). Anyone else experiencing this? Is there a solution?
Cheers
 

kaktus1389

New member
Feb 7, 2016
793
0
0
Visit site
I only had issues with facebook, but that was the case with facebook on all browsers as they have some "long scripts" running. Before I used to get the same message while browsing Windows Central, but now I somehow don't get those anymore.
 

badelhas

New member
Dec 17, 2015
354
0
0
Visit site
I only had issues with facebook, but that was the case with facebook on all browsers as they have some "long scripts" running. Before I used to get the same message while browsing Windows Central, but now I somehow don't get those anymore.
But did you do anything to fix it?
 

kaktus1389

New member
Feb 7, 2016
793
0
0
Visit site
Nope, looks like for me it just works sometimes but it sometimes also has a bad day as yesterday I didn't get that message even once but today I already got it 3 times, lol...
 

badelhas

New member
Dec 17, 2015
354
0
0
Visit site
Nope, looks like for me it just works sometimes but it sometimes also has a bad day as yesterday I didn't get that message even once but today I already got it 3 times, lol...
So it's general and I'm not the only one with the issue. I feel better :) Do you have the couple of cumulative updates that were launched for the 1607 windows anniversary version? Can you please check it?
Thanks
 

Lightning_Racer

New member
Dec 19, 2015
30
0
0
Visit site
Edge is almost unusable now for me at times starting in the same time frame. Adblock also stopped working, even with an uninstall/reinstall. I'm using a Surface Pro 3, and I was on insider preview slow ring. I turned off insider previews to see if it would help, and it hasn't. I hope Microsoft comes up with a fix soon.
 

badelhas

New member
Dec 17, 2015
354
0
0
Visit site
Are you all still experience this problems like myself? I would think that by now Microsoft would have released an update to fix this since Surface users are experiencing the same, from what I read...
 

tbsteph

New member
Oct 15, 2013
90
0
0
Visit site
Yes! Many websites cause the recover page notification (If you are very patient, it will eventually load, sometimes.). Most commonly I encounter this issue when hitting the back button. It has been this way for sometime now. For me, it makes Edge a not worth the effort.
 

hovesteve

New member
Nov 1, 2012
48
0
0
Visit site
Glad I'm not the only one. Since the AU update Edge has been becoming more unresponsive (freezing all the time) This is on a SP4 and Dell AIO. I've had to resort to using Chrome :-(
 

Lightning_Racer

New member
Dec 19, 2015
30
0
0
Visit site
I solved my problem by reseting Edge. It must have gotten corrupted during the recent updates. It was a pain in the *** to do - figuring out how to enter safe mode in Windows 10 (needed to figure out how to get the bitlocker code), and then restoring my bookmarks afterwards from another browser. Then reorganizing the bookmarks... But it seems to run fine now, and Adblock, after a uninstall/reinstall during the Edge reset process, this time now works again.

I got the tip from the Adblock support page: https://help.getadblock.com/support...r-the-options-page-is-empty-in-microsoft-edge

The Adblock page points here for the Edge reset process: Reset Microsoft Edge browser to default in Windows 10

I wonder if Microsoft would have fixed these problems with updates at some point if I had not done anything to reset Edge. I kind of don't have faith that they would have... that could have possibly left Edge unusable for the rest of the life of my Surface Pro 3, if I was less computer savvy, like my parents.
 

tbsteph

New member
Oct 15, 2013
90
0
0
Visit site
This issue has plagued my usage of Edge for some time. After trying every fix I could find (To no avail) I changed the "proxy setting" from automatically detect to off. (I am not using any proxies.). Well, what do you know, I haven't seen the reset web page message since. Edge is now quite responsive - first time ever.

Update 9/28/16 Well, that did not last long. Issue seemed to disappear only to come back into it's own glory. Downloaded Opera, which works just fine! Unbelievable MS would leave Edge in such a deplorable condition.
 
Last edited:

Members online

Forum statistics

Threads
324,095
Messages
2,244,971
Members
428,166
Latest member
kasha963