Help! 1520 seems to be dying after 2 years

Jun 12, 2017
2
0
0
Visit site
I've had my white 1520 for two and a half years and it has held up well until now. It has been running the release version of W10M since March 2016. A few months ago I stopped using it as my primary device. It is a phone I dearly love, so I am sad to say that it seems to be on it's last legs.

I've tried using it lately but have a problem. At random times during use, the phone instantly dies. There is no vibration - just instant black screen. It will then fail to reboot; sometimes getting to the blue 'windows' logo and other times only getting to the Nokia logo before going black again. It only turns on successfully whilst being charged. Once it turns on, I typically find the battery at 20-30%; although this can happen less than an hour after being fully charged.

I assumed this was a Windows 10 glitch (I've had MANY on phones), so I reinstalled Windows Phone 8.1 last night, but the issue still happens. 20 minutes ago, it died suddenly so I placed it on the wireless charger. When rebooted it showed 31% - 20 minutes later it is 100%! The wireless charger typically takes 2-3 hours to charge it that much...

I've never seen this problem in any WP before. Physically the phone appears in mint condition. It seems like the OS is not reading the actual battery %? What can I do?

Thanks!
 
Jun 12, 2017
2
0
0
Visit site
Thanks for the replies. That sounds bad, oh dear...

Interestingly, on the Battery app, it only shows a drop to 80% or so when the phone's battery saver app in settings reports 31%...

Is this a common issue? I have been wirelessly charging this thing for two years so maybe that has shot the battery. Anything I can do, aside from physically replace?
 

Members online

Forum statistics

Threads
323,085
Messages
2,243,224
Members
428,020
Latest member
mow