HELP! I've tried almost everything I can think of and I can't get the firmware to update!


New member
May 30, 2017
Visit site
Hey guys - just purchased a Surfacebook i5 128gb 8GB (base model) new. Unfortunately due to being out of the the United States at the moment a return is not possible unless as a last resort.

Here's the issues I have currently noticed.
- FIRMWARE: Surface Embedded Controller Firmware, Surface Management Engine, Surface Touch, Surface UEFI. [confirmed with photo of UEIFI BIOS showing old version 88.858.768 instead of](
- Battery not charging (Keyboard dock is charging fine however tablet is not: both connected to dock and directly to power source) [Here is a picture of the battery report generated by windows. As you can see it looks like one of the batteries has never been engaged](

All of the firmware are all stuck on either (1/05/2015) or alternatively on the most current firmware and not working. I have attempted to

- update them via device manager and they download but show a false installation. [see picture showing different driver states in device manager + battery charge and windows version](
- download the .msi and install as well as manually install the drivers via the .zip file.
- force windows to update via command prompt
- Reset PC
- Go back to previous version of Windows.

When I restart it shows the firmware update beginning for maybe half a second or so then flashes off a few times before rebooting. I can see it windows thinks it has installed the firmware but from observation it has not.

As you can see the battery is fully charged on the keyboard but the tablet itself is not charged. I removed the tablet from the keyboard and tried plugging it directly into the power cord and it did not charge which leads me to think that it's a software communication issue.

I've spent the last 12 hours or so troubleshooting and have tried some stuff I forgotten to list so if anyone has any help or tips or anything please please please help. I'm not used to the locked down nature of the BIOS of the Surface so I was originally thinking I could update the firmware via that but it doesn't look like that is possible.

**TLDR** Bios stuck on old version, Firmware won't update to latest version but thinks it has, Tablet power won't charge via dock or straight cable.

Members online

Forum statistics

Latest member