How can I get Cortana working, Edge immediately closes?

  • Thread starter Windows Central Question
  • Start date

Windows Central Question

Cortana not working, Edge immediately closes

Hello. Im not sure if this is correct catorgory but if not let me know.

I have a toshiba laptop upgraded to windows 10. About a week ago my start menu, Cortana, & several other windows apps (calculator, etc) stopped opening at all. I did a system restore to about a week before. System restore took an unusually extremely long time but seemed to work.

NOW Cortana responds to Hey Cortana, but then the little corner cortana box just sits there, & cortana never speaks, nor searches, nor acts like it hears me.

My start menu opens normal but EDGE acts like its going to open, but before I see anything other than the blue background, it closes (no notification or anything). It does the same thing if i click a link to support ot something & get same result nomatter if using my taskbar icon, desktop, or startmenu.

Calculator, Word, etc all seem to work fine.

I thought I'd try restoring to previous time again however though i had 3 different restore point options when i restored the 1st time (&i had chosen the most recent), it shows no previous restore points & shows no space being used for restore storage!

Ive found some similar problems when i tried searching for solutions, however they all had AVAST installed, which i do not.

Could anybody help me with a good solution? Thank you very much for your time & assistance.

UPDATE: I was told at microsofts support to check to see if I gotten the upgrade. I looked and it showed failed on 11/16. They had me manually upgrade the build. It took forever but finally finished. Now my xbox app works but CORTANA doesnt even respond to "hey Cortana" & EDGE does still the same thing! grrrrrrrrr Its also been really slow/laggy in EVERYTHING I do since I did the build upgrade.

UPDATE= on another forum I was asked if I had gotten the new build upgrade. I checked my update history & found on 11/16 it failed, however it doesn't give option to retry. Any clue how to retry build failed upgrade too?

Members online

Forum statistics

Latest member