Just got the Icon, really impressed!

mcherrick68

New member
Nov 14, 2012
88
0
0
Visit site
After dipping my toes in the Android pool for a few months, I'm back on Windows Phone with arguably the best WP available, the Icon! I found a really good deal on swappa for a used icon, and I couldn't pass it up. I have used an 822 and a 928 previously, so I knew what to expect as far as software goes, but the Icon takes everything to the next level. The experience can only be described as "butter". This thing flys! The hardware just oozes quality, too. The buttons feel amazing, which is something so many phones don't pay attention to, save for the iphone. The screen is not only bright and sharp, but the coating on the glass mixed with the curved edges make my finger glide over the screen like nothing I've ever felt before. I have only taken a few shots with the camera, but so far, I've been blown away by the images it takes. I thought this phone would much thicker than it is, but it's surprisingly svelte, although it is pretty dense. I really don't wanna ruin this beautiful thing by putting an ugly case on it, but I know I must since I accidentally drop my phones on a daily basis. I've never owned what I consider a pretty windows phone before, (822 is pretty gross looking, as well as the 928), so I just want to show this thing off!

One issue I'm having is the power button is having some delay between when I press it and when the screen comes on, about 1.5 seconds or so. I am running the DP, and I read that some people do have issues with the power button sometimes. It is weird though, the first day I got the phone, the power button was consistently malfunctioning, but the next day, it performed flawlessly, and now today, it is malfunctioning again, so I'm a bit confused. Do you guys just recommend trying a hard reset? I really don't want to do that since I just got everything setup exactly how I want it, but I will do it if I have to.
 

11B1P

Active member
Sep 5, 2011
1,481
1
38
Visit site
I've noticed with mine, it used to seem like it depended how long it had been since the screen had been locked. Now it seems like it is instant on response.
 
Last edited:

Ed Boland

Retired Ambassador
Nov 17, 2012
4,704
5
38
Visit site
Welcome to the high end of WP currently. You very well described how I feel about my 1520 (the same specs and camera as the 930/Icon) Buttery smooth indeed, beautiful screen, and outstanding build quality!

I've never experienced this delay you're talking about though with the power button. I'm also on the latest 8.1 DP update 1 with Cyan though. Last I heard, the Icons on Verizon hadn't yet received the Cyan firmware.. maybe that'll fix your problem?

3-4 second delay? I wouldn't be ok with that!
 

Daniel Olsen

New member
May 3, 2013
117
0
0
Visit site
When I had a 1520, I disabled glance and had the same delay issue. Now with the 930 (same thing with the icon) I'm assuming that the delay is because of the lack of glance. It's most likely a firmware bug.
 

mcherrick68

New member
Nov 14, 2012
88
0
0
Visit site
I'm hoping that the delay issue gets fixed with a firmware update. I'm really hoping they just abandon all work on cyan and completely devote there resources to bringing denim to the Icon. Passive Cortana would be a game changing feature I think.
 

Members online

Forum statistics

Threads
324,170
Messages
2,245,090
Members
428,172
Latest member
plantsulinupdate