multiple display setup

Jan 20, 2013
50
1
6
Visit site
I purchased an i5 SP7 to replace my aging SP3. I was hoping for it to be a drop-in replacement but unfortunately not as I can't get multiple displays working. Previously I used the Surface Pro 3 docking station mini-display port and SP3 mini-display port to drive 2 HDMI monitors. The docking station mini-display port is not working at all with the SP7. I also have a Lumia USB-C dock which works perfectly with the SP7 ... except for the display port. HDMI and all other ports work fine. So again, just one monitor.

I've been unable to find a decent USB-C hub with multiple HDMI ports and ethernet that doesn't break the bank. I bought a Satechi USB-C hub and now successfully have one HDMI external monitor and my USB-A peripherals connected but it only has the one display output.

I'm thinking perhaps a USB-C to dual HDMI adapter daisy chained on the Satechi hub but it's sole USB-C port appears to be for power in only. As a side note the SP7 is refusing to charge via USB-C either directly or via the hub, failing to detect all but my old Lumia hub power charger, and not charging with that one.

I don't want to risk buying all new daisy-chainable monitors to discover they don't work.

What are other people's solutions?
 
Jan 20, 2013
50
1
6
Visit site
For anyone interested, finally got the dual external monitors working by using the Satechi USB-C hub plugged in to the SP7 USB-C and a USB-A to HDMI adapter plugged in to the SP-7 USB-A
 

superbondbond

New member
Feb 7, 2020
3
0
0
Visit site
We have two SP7s that we bought to replace our Surface Books. We were using (presumably) the same surface docks (model 1661) previously to run dual external monitors.

We had the extras screens running perfectly through the dock until a few days ago when both SP7s received some windows updates, at which point the external displays no longer work. Everything else with the dock works fine - audio, USB, charging. It's the displays the no longer work. In fact, the Windows display settings shows two additional displays connected, I just can't activate them.

I know the problem is not with the docks as they both still work fine with the old Surface Books.

It seems like the latest Windows update "broke" the SP7s ability to run the displays through the dock. We had the external monitors running perfectly for about two weeks prior when we first received the SP7s.

I'm hopeful there might be a fix to this if it's a problem in the SP7 firmware/drivers. But that would only come from MS via a future update.
 

Members online

No members online now.

Forum statistics

Threads
323,709
Messages
2,244,260
Members
428,106
Latest member
Akashdeep3469