My Band 2 Bluetooth won't turn on

Marsamver

New member
Sep 29, 2011
27
0
0
Visit site
I've literally only had it three days. . . . gutted - Here's my tale of woe -

I just put my Band 2 on charge as it was down to about 15% then checked later and it was up to 95% so I put it back on my wrist. I then just noticed that the last data sync on the MS health app was this morning.

I checked the bluetooth on my Lumia 930 and the band was showing paired, but not connected.

Next went into the Band 2 settings and bluetooth was off! Selected it it to on, and it immediately went back to off again. tried this a couple of times and even tried selecting "pairing" but it just switched back to "off" Restarting the band/phone/app didn't fix it, no bluetooth symbol and still stuck to "off"

I tried all the usual things, removed from my Lumia's bluetooth, un-installed the Health app, tried again, no luck, repeated the same but this time factory reset the Band losing today's data. Still no luck starting from scratch. The Band was now stuck at the reset point as I couldn't setup the initial pairing.

Then, while sadly writing this post, I tried again, it's still wasn't finding the Band so I thought I'd look on my PC, and there it was showing up in the bluetooth list! Then I saw it appear on the MS Health app on my phone!! "I've done it", I thought. . . . . but twas too soon to speak, as about thirty seconds after I put the band back on my wrist the bluetooth went off again, stuck on off, wont turn back on. . . . . . . gutted

Oh well, it was a fun three days, loved the Band 2, but now I guess go through the process of a return and replacement if I can't get it back to life with more tinkering :unhappy:

May just return it completely, as the posts here are enough to put me off now I've had my first major issue.
 

Brian Gobrecht

New member
May 20, 2013
132
0
0
Visit site
you didnt have to lose the bands data. you could of installed the Band Sync App on pc/mac and sync it to get accurate data. ad to the bluetooth you probaby need to take a trip to the MS id you have one or wait a week for turnaround via snail mail.
 

Marsamver

New member
Sep 29, 2011
27
0
0
Visit site
Cool, thanks, being new to the Band 2 I didn't know there was a USB PC app. Just tried it and got last nights sleep data. Then, looked at the Band and bluetooth was back on!! If i keeps happening I'll have to look at sending it back, no MS stores here unfortunately.
 

Marsamver

New member
Sep 29, 2011
27
0
0
Visit site
Unfortunately the Bluetooth "off" issue came back and this time wouldn't go away. Factory resets etc still no bluetooth at all and switching it on switches back to off itself.
It's winging it's way back to MS via UPS for repair/replacement.
 

DroidUser42

New member
Nov 7, 2014
1,026
0
0
Visit site
When you say it's "off" what are you looking at? If you're talking about the BT symbol you see when you swipe right from the main screen, that's lit only if it's connected. Usually when I have BT issues with my Band, it means I have to cycle the BT on/off on my phone so things connect up again. But then, I'm running Android.
 

Marsamver

New member
Sep 29, 2011
27
0
0
Visit site
When you say it's "off" what are you looking at? If you're talking about the BT symbol you see when you swipe right from the main screen, that's lit only if it's connected. Usually when I have BT issues with my Band, it means I have to cycle the BT on/off on my phone so things connect up again. But then, I'm running Android.

No it's off completely, no BT symbol when I swipe right, so I go into the settings on the band and BT is switched off. I turn it back to "on" on the menu but it immediately goes back to off, pairing option also not working. Followed all standard troubleshooting inc factory reset, BT is dead.

It's in Germany for repair/replacement so will wait and see.
 

Marsamver

New member
Sep 29, 2011
27
0
0
Visit site
Well I've received another Band, I think it's a different one anyway! I had to look up the serial number to figure this out as it's different than the one I originally had on the service request.

Took about a week turn-around from Germany to UK.

It would be good for some information or, you know, some words! to tell me whether it was a replacement or repair and what the issue was, as this wasn't clear on the service website either, it just tells me they shipped it back, but another email said "Your item will be reviewed by our exchange center and a replacement will be processed. Your replacement item will ship soon"
It wasn't brand new in the box, but it looks as good as new.

pleased that everything is working, even Cortana as I hadn't got this to work properly until now!
 

Members online

Forum statistics

Threads
324,267
Messages
2,245,271
Members
428,181
Latest member
jruasap