New update AFTER Amber+GDR2

Vituz

New member
Aug 6, 2013
5
0
0
Visit site
Hi all,

I just received a notification of a new update for my Lumia 920. That was totally unexpected, as I installed my Amber update already in August. I couldn't resist so I installed the update. It took a good half hour to install it, so it seemed to be a big update. But at first glance it seems nothing has actually changed!

Is any of you guys aware of this or had the same experience? I was hoping this time I would get Data Sense but unfortunately it's still not there (my 920 is unbranded dammit!!!!!!!!).

Thanks for any tips,
Vituz
 

WanderingTraveler

New member
Dec 23, 2012
4,974
0
0
Visit site
Yup, that's it.

I have an unbranded phone AND Data Sense.

As for the various Nokia improvements, try updating extras+info.

If all else fails, you'll have to send it to Nokia for troubleshooting.
 

multo

Active member
Nov 19, 2012
1,014
0
36
Visit site
region based update perhaps? on the nokia global page majority still have the 1326 version for the 920
 

Jeff Merritt1

New member
Feb 1, 2013
103
0
0
Visit site
I'm still waiting for the update on AT&T. I switched from T-Mo because I thought it was going to be a better experience with updates and all...wow, was I proven wrong...should have stuck with them.
 

DalekSnare

New member
Apr 4, 2012
273
0
0
Visit site
I'm still waiting for the update on AT&T. I switched from T-Mo because I thought it was going to be a better experience with updates and all...wow, was I proven wrong...should have stuck with them.

Well, to be fair the AT&T network is nice. I got 50 Mbps down on LTE at a restaurant the other day! But I'll probably switch to Verizon when my contract's up because they did a good job of not miserably failing to release GDR2/Amber. GDR 3 and 8.1 will happen before my contract's up though, so maybe AT&T will change their ways before then and redeem themselves.
 

Jeff Merritt1

New member
Feb 1, 2013
103
0
0
Visit site
I understand their network is decent, one of the main reasons I switched. However as of late I keep hopping between 4G and LTE...plus the update debacle. They all have their bad points.
 

TruPlaya187

New member
Oct 19, 2011
741
0
0
Visit site
There was another post at one point that somebody saw that 1330 update on the Nokia servers.
http://forums.windowscentral.com/no...ate-3049-0000-1330-xxxx-nokia-care-suite.html

If you have a chance, could you check if the post-processing for the camera has changed a bit. Somebody else on this site told that he received also an update a couple weeks ago and the post-process was reduce a lot...I am wondering if this update would fix the camera bug...
http://forums.windowscentral.com/nokia-lumia-920/237916-5.htm
That was his post : An update came out in Australia for unbranded devices a couple of weeks ago. The only real changes in it were for the Camera and I noticed the Post Processing was reduced in severity a LOT... I'd post samples but I now have the 1020 and am eagerly awaiting the update for it... If you have a 925 I highly recommend flashing it with the latest updates...
 

Vituz

New member
Aug 6, 2013
5
0
0
Visit site
Guys, so this update is giving me huge problems. In the last days the phone froze twice and I had to force restart it. The last time resulting in the fact that photos are just not saved, the time settings were changed and I cannot send texts anymore. And these are only the problems I have found on the last 30 minutes. I'm so annoyed I have to take it back to the store under warranty. At least 10 days without phone, which I also use for work. I'm so pissed!!
 

peacock93

New member
Dec 14, 2011
139
0
0
Visit site
Guys, so this update is giving me huge problems. In the last days the phone froze twice and I had to force restart it. The last time resulting in the fact that photos are just not saved, the time settings were changed and I cannot send texts anymore. And these are only the problems I have found on the last 30 minutes. I'm so annoyed I have to take it back to the store under warranty. At least 10 days without phone, which I also use for work. I'm so pissed!!

Did you try a Hard Reset? My Vibrate would not work when I updated to GDR2/Amber and a Hard Reset solved the problem. Just make sure you've either backed up all of your pics and anything else you want to save before you do it!
 

tungha

New member
Dec 27, 2012
212
0
0
Visit site
I can confirm this update fixes the screen flick issue when scrolling.
The camera seems slightly improved, iso and wb still not correct with auto
 

Vituz

New member
Aug 6, 2013
5
0
0
Visit site
I managed to fix this... I made a hard reset, then I let the battery die, plugged it to power and after a while found it switched on... So glad I didn't have to send it back for repair...



Sent from my RM-821_eu_euro2_224 using Tapatalk
 

Members online

Forum statistics

Threads
322,442
Messages
2,242,009
Members
427,925
Latest member
JoseStut