• Welcome to the all-new Windows Central Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues, please let us know in this thread!

No Install button on Windows Store


New member
Jul 30, 2015
Hi all,
So I've just upgraded to Windows 10 and I can't seem to install any apps from the store, there is no Install button? I click on an app(facebook for example), the facebook app page loads but no Install button appears. Also the blue loading dots just keep spinning and then the app crashes after a while. Anyone else ran into this?

I've tried everything from wsreset.exe to cleaning out the C:/Windows/SoftwareDistribution folder. I've also tried refreshing the pc and deleting and re creating the user account with no success.


Steve Thackery

New member
Jun 23, 2015
That's weird. I've just looked at the store entry for Facebook on mine, and there is definitely an install button.

I'm sorry this is of no help, but it does suggest there is something specific to your particular installation, rather than a widespread problem.