RDC on Windows RT 8.1

narv

New member
Nov 24, 2012
307
0
0
Visit site
So for the longest time I've been able to remote connect to my desktop computer from my windows RT machine. Last night, I decided to just go ahead and put the windows 8.1 preview to see what it's about. One of the things I noticed is I can't seem to use RDC anymore to connect to my desktop. Nothing has changed otherwise. However, when I do look at the system properties for remote, I only have the assistance section, and not the remote desktop section like I do on my PC. Was this feature removed for RT?

Thanks.
 

jaimeastin

New member
Apr 8, 2012
486
0
0
Visit site
From the start menu, type or search for remote desktop. Also, download the metro rdc app and try there too. Make sure the network you are on is trusted... I don't know... I would think nothing is missing...

Although I am an advocate to eventually drop desktop mode, it is still one of the most important things windows tablets have! I hope the RDC is still there...
 

azcruz

Active member
Jul 29, 2013
3,417
0
36
Visit site
I've been using Remote Desktop on my Surface RT since 8.0 and now 8.1 Preview. What version of Windows 8 do you have on the remote machine?
 

narv

New member
Nov 24, 2012
307
0
0
Visit site
@azcruz I have windows 8 pro on the remote machine.

@jaimeastin I have the remote desktop client open, since it's what I used before. I didn't try the app so I guess i'll try that when I get home from work this afternoon. The network should be trusted, I mean I've used it before, last time I used it was last weekend.. Nothing has changed on my end. The ports are still forwarded on the router, using the same Microsoft account (on both machines), and I checked the settings (again, windows 8 pro) and it is checked to allow connections.
 

bradbamford

New member
Oct 29, 2012
131
0
0
Visit site
I only have the assistance section, and not the remote desktop section like I do on my PC. Was this feature removed for RT?

No, the remote desktop section was never there on the RT version.
That setting is only for incoming remote desktop which RT doesn't allow.
Make sure you have port 3389 open on your PC's windows firewall. For testing just turn off Windows firewall on your PC.

Also, you don't need ports forwarded on your router unless you are trying to access your PC while away from your home network.
 

azcruz

Active member
Jul 29, 2013
3,417
0
36
Visit site
@narv, on your desktop go to System Properties, Remote tab, Allow Remote Connections is good?

Then just initiate RDC from your RT and specify the name of your desktop PC.

Sent from my LT25i using Tapatalk 4
 

narv

New member
Nov 24, 2012
307
0
0
Visit site
@bradbamford Okay.. I wasn't entirely sure if I had it there or not before so thanks, at least I know it's not missing now. I do use it to connect to my desktop computer from outside of my home network which is why the port forwarding is setup. I didn't try turning the windows firewall off but i'll give that a go and see what happens.

@azcruz I did check that the allow remove connections is checked, and I tried with the 2nd option for authorized users on and off. as well as making sure my user name was added in the list there.

I went to whatismyipaddress.com to make sure I was connecting with the correct IP. Maybe i'll try rebooting the machine, see if that works.. ya never know.

Also, since it seems I never posted the actual error message (though im sure you could all guess it as the standard "doesn't work" one):
The client could not connect to the remote computer. Remote connections might not be enabled or the computer might be too busy to accept new connections. It is also possible that network problems are preventing your connection. Please try your connection again later. If the problem continues to occur, contact your administrator.

Thanks all for the help.. I'll try it out and get back to you all in a few here.
 

hotphil

New member
Nov 14, 2008
2,008
0
0
Visit site
I had similar issue last week. I didn't confirm, but I put it down to a recent Windows Update re-enabling Windows Firewall. Grrrr.
 

DaveSC

New member
Jan 4, 2013
72
0
0
Visit site
RDP works fine on WinRT8.1
Use the metro app or run the command mstsc (winkey + R to bring up run dialog). Type in the IP or the Hostname if on the local network for your pc. As stated above if you want to RDP from a remote location you need to open port 3389 in your firewall and point it at the machine you want to control. I would suggest using a different port like 13900 on the outside then 3389 on the inside so the RDP bots don't find your connection easily. This also allows you to setup multiple machines on your network with rdp connections even if you don't have multiple ip's without the need for a Terminal Services Gateway. PC 1 = 13900, PC 2 = 13901 and again on the inside 3389.
 

Members online

Forum statistics

Threads
323,721
Messages
2,244,279
Members
428,103
Latest member
peng