[Repost from MSFT] Windows 10 Creator's In-Place Upgrade Error: 0x8007042B - 0x2000D

Mar 9, 2016
41
0
0
Visit site
Okay, I'm just throwing this out there since Microsoft's habit seems to be "reply once per forum post" and I'm not getting any additional assistance from Microsoft.

Here is my original thread post:
Hi there,

I have a serious problem with my system. From a superficial view, everything runs normally. However, when running system file checker, it says, "Windows Resource Protection found corrupt files but was unable to fix some of them." I then run DISM /Online /Cleanup-Image /RestoreHealth and it says, "The file or directory is corrupted and unreadable." I also try to run Dism with an ISO file as reference, but it shows the same error message. I then try to run an in-place upgrade with an ISO file, and when the installer reaches 12% after the first restart, it automatically shuts down. It then restarts only to display, "Restoring your previous version of Windows..." I log into my user account and a dialog appears that shows this message: "0x8007042B - 0x2000D The installation failed in the SAFE_OS phase with an error during MIGRATE_DATA operation." If I can't run an in-place upgrade, this means that I would have to restore from an earlier system image, which is something that I don't want to do. Can anyone help me figure out how to make the in-place upgrade work again? It worked perfectly two months ago. Thanks.

And here is the response from the first person who only replied once to my Microsoft forum post:

Justine Pel replied on 6/18/2017 2:46:52 PM: Microsoft Forum Moderator

Hi,

This issue occurred due to some corrupted files. We suggest performing a clean boot to check if there's any third party application is causing the issue.

If the issue still persists, we recommend visiting this link to help you understand and resolve your concern.

Get back to us if you need further assistance.

In which I replied with no response back:

Replied on: 6/18/2017 3:35:17 PM

Ok. I will try this. But, why would a clean boot affect Windows setup running before Windows even loads?

Here is the second response:

Andre Da Costa replied on 6/18/2017 3:02:34 PM: MVP Insider, Community Moderator, Wiki Author, Conversationalist Launch expert, Windows 10 Wiki Master

What is the make and model of your computer?

Have you checked the manufacturers website to determine compatibility?

Check this List to Determine if Your Computer is Compatible with the Windows 10 Creators Update or Anniversary Update or Not

You should also follow Microsoft's advisory and upgrade only when offered through Windows Update:

Microsoft Slows Rollout of Windows 10 Creators Update based on Customer Feedback

If must upgrade, perform the following tasks:

12 Things You Should Do Before Installing Windows 10 Creators Update (Version 1703)

If the Windows 10 Upgrade Assistant becomes stuck or unresponsive at various percentages: 0%, 32%, 62%, 87%, 99%, please wait at least 4 to 7 hours. If you are updating through Windows Update, when the download reaches 99% disconnect from the Internet LAN (Ethernet) or Wi-Fi then proceed with the installation.

If setup does not progress, close the wizard then restart your computer. Follow the instructions to upgrade manually using the Media Creation Tool or the Windows 10 ISO file.

How to download official Windows 10 ISO files

How to Upgrade to Windows 10 Creators Update version 1703 using ISO File from Versions 1507, 1511 and 1607

In which I responded:

Replied on: 6/18/2017 3:48:31 PM
Thanks for the reply, but your reply doesn't answer my question. In fact, it opens more questions than answers. My PC is a Lenovo Thinkpad T560, which is only a year old. It is in the list of supported PC's and I would be surprised if it wasn't. I already mentioned that I was using an ISO file, and I always upgrade from an ISO file for these reasons:

  • There is no way for the user to check the integrity of the downloaded files from Windows Update before they are installed to the computer. We cannot be certain that there is an internal file hash check. The only way to be sure is to download an ISO file that can be hash checked for integrity.
  • I always do a in-place upgrade after the new upgrade. I am currently running the Creator's Update now. I previously mentioned that I ran an in-place upgrade 2 months ago. The in-place upgrade assures that remnants of the previous build don't linger in the new build, preventing most bugs and issues with the latter.

I've also received all the cumulative updates since the official release of the Creator's Update. I apologize if I sound critical, but I assure you that I've done my research on the Creator's Update. I just can't find an answer as to why I cannot run in-place upgrades anymore. Can you assist me with a more specific solution?

I also apologize for reposting my entire thread from Microsoft, but I was hoping that someone here can give me some insight as to why this is happening, or if someone here experienced this problem and fixed it. Thanks.
 

Members online

Forum statistics

Threads
323,701
Messages
2,244,244
Members
428,102
Latest member
Korshun