• Welcome to the all-new Windows Central Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues, please let us know in this thread!

[Solved itself. Somehow] Cannot add Microsoft Account after switching to local Account


New member
Jul 1, 2015
Aaaaaaaah! Wasted Time: A few minutes after I wrote the below post, Win10 asked for another restart. I said "Yes" and after that I was able to switch to the MSA again. Account on my Machine is also verified.

I dont know what reason was, for the Problem. And as I did a lot of things, I really cant say what fixed in the end lol
It was definitely not a restart needed from SFC or DISM.
Maybe a very long delayed (a few hours) restart order from the MSA Trouble Shooter? Not sure.

Yesterday, I did a clean Install with Build 10158. When prompted to add / create an Account, I added my MSA and everything worked fine.

Windows Update then wanted me Verify my MSA to be able to get Insider Builds. Ok then:
1.) Clicked on "Verify"
2.) Entered my eMail
3.) Got the Security Code
4.) Entered Security Code
5.) Done. No Error

After 2 restarts, I still got the 'Pop-In' that says: "Get Insider Builds: Insider Build Settings need some Attention". Next Phase:
In the Windows Update -> Advanced Screen, I clicked on the "Fix me" Button. Nothing happened.

I have searched through the Web. As there are only kind-of-Solutions for Windows 8/8.1:
1.) I decided to switch to a local Account
2.) Did a restart
3.) Logged in with the new local Account again

I went back to the Settings -> Accounts -> Your Accounts.
1.) Clicked on "Sign In with a Microsoft Account instead".
2.) No reaction.
3.) Tried the "Fix me" Button in the Windows Update Section again: The Dialog "Hey, are you an Insider? .." came up, but when I click on "Switch to a Microsoft Account": No reaction.
4.) Checked the Web again
5.) Removed the MSA Account completely.
6.) Repeated the above Steps but still no Luck

1.) Unzipped the Windows 10 Build 10158 ISO to a Folder and started the Setup.exe overnight [keep Windows and Windows Settings, Programs etc.]
2.) Can still not add a MSA
3.) Did a quick search through the Web again and tried the Microsoft Account Troubleshooter for the 'LEFKPM-Problem' - just in case.
4.) Oh look: Now, when I click on "Sign in with a Microsoft account instead", a white Window with the blue rotating circle appears, that says "Just a Moment". But "Just a Moment" keeps going on and on and on...

1.) Yes it is a Administrator Account
2.) I already tried
dism /online /cleanup-image /scanhealth
dism /online /cleanup-image /checkhealth
dism /online /cleanup-image /restorehealth
sfc /scannow

No Errors was found. Even before I did the reinstall overnight.

I never had such Problems with Windows 7. Has anyone another Idea? As there is no Windows-Easy-Transfer Tool anymore, I cannot backup my Settings and Files to restore them after another Clean Install. In fact, I had to backup everything manually by copying it piece by piece. I hope I dont have to do this again.

Last edited: