• Welcome to the all-new Windows Central Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues, please let us know in this thread!

SP3 not connecting to internet - help needed


New member
Jul 29, 2013
All of a sudden my SP3 is not connecting to the internet. I looked in the device manager to check on the network adapter and the Marvell wireless network controller is not running properly. The error message is Code 12: This device cannot find enough free resources that it can use. Also, under details tab, problem status, it says "conflicting address range. The specified address range conflicts with the address space."

I've tried uninstalling the driver and restarting, but to no avail yet. I tried system restore, but it only went back to yesterday afternoon. I had this issue yesterday morning, but it resolved on its own.

I know the Marvell adapters are notoriously buggy.

Any help or suggestions?? I'm at a loss right now.

**Update: After shutting down and restarting numerous times, the connection has been restored. What's the deal though? I don't want to go through that every time. Also, the bluetooth adapters were not showing up during that issue, but are now showing.
Last edited: