T-Mobile APN Settings

antiochian2010

New member
May 11, 2013
451
0
0
Visit site
If you are a T-Mobile USA customer, the following might save you from 3 days of frustration and numerous 611 calls I made..

If you are showing LTE but can't access websites or make MMS work, try the following:

Go to Settings..Cellular. Scroll down until "Add Internet APN" and "Add MMS" buttons appear.

Apply these settings:

Internet APN -
Change APN field to "fast.t-mobile.com"
(don't. forget the hyphen in "T-Mobile".. it DOES make a big difference)
Leave all other fields alone!! Hit save

MMS APN -
Change APN field to fast.t-mobile.com
Change MMSC (URL) to mms.msg.eng.t-mobile.com/mms/wapenc

Hit save

Since figuring this out from various threads and boards, my phone is working like a dream!
 

brandoshido

New member
Dec 25, 2011
29
0
0
Visit site
If you are a T-Mobile USA customer, the following might save you from 3 days of frustration and numerous 611 calls I made..

If you are showing LTE but can't access websites or make MMS work, try the following:

Go to Settings..Cellular. Scroll down until "Add Internet APN" and "Add MMS" buttons appear.

Apply these settings:

Internet APN -
Change APN field to "fast.t-mobile.com"
(don't. forget the hyphen in "T-Mobile".. it DOES make a big difference)
Leave all other fields alone!! Hit save

MMS APN -
Change APN field to fast.t-mobile.com
Change MMSC (URL) to mms.msg.eng.t-mobile.com/mms/wapenc

Hit save

Since figuring this out from various threads and boards, my phone is working like a dream!

Many thanks. I'll be returning to this thread when I unlock my 1020.
 

morete908

New member
Jan 25, 2013
11
0
0
Visit site
Yeah, or just go into T-Mobile and tell the rep to use the two APN settings they are using in their Galaxy S 4 that all of them own and use as their primary phone. It worked for my 1020. Without those APN's you can kiss picture text messaging goodbye.
 

Eric Angeles

New member
Sep 21, 2013
1
0
0
Visit site
I'm using a Lumia 900 and I don't have add APN when navigating the exact method you used. Is it because I installed network setup app? Something similar to this worked for a few days and now it doesn't.
 

jumped ship

New member
Sep 17, 2013
4
0
0
Visit site
UPDATE Sept 21...

Had these settings and they worked great but now I am unable to access the internet and MMS. Anyone else experiencing this?
 

jumped ship

New member
Sep 17, 2013
4
0
0
Visit site
It's very strange too because tiles have no problem updating but I have not been able to access the web with full bars LTE included. Please save this noobie.....
 

roastbeefalo

New member
Oct 30, 2012
22
0
0
Visit site
Hello, I have the Nokia Lumia 900 phone from AT&T, AT&T unlocked it, and I moved over to T-mobile and was not able to send MMS photo text messages. I used the app Network Setup by Nokia for my Lumia 900 and it works for me to send MMS with photos. I just ran the app, it said my settings have been updated, and now it works.
 

johnnypdx

New member
Jul 16, 2013
4
0
0
Visit site
THANK YOU for this! The dash makes all the difference. I'm not getting that information from most of the other sources out there.
 

Harmdizzle

New member
Dec 2, 2012
46
0
0
Visit site
hi guys,
i've tried posting in the nokia icon forums, but no answers there. i can send MMS fine, but i can't receive. i've tried using the settings from above. any ideas?

thanks!
 

hasasimo

New member
Apr 8, 2012
1,922
0
0
Visit site
hi guys,
i've tried posting in the nokia icon forums, but no answers there. i can send MMS fine, but i can't receive. i've tried using the settings from above. any ideas?

thanks!

Seems like everyone using an Icon on T-Mobile is having MMS (and other) issues. You may need to just import a Lumia 930.
 

CJ Thunder

New member
Feb 16, 2011
714
0
0
Visit site
I know this is an old thread...but it worked, on W10m.
I just went back to 8.1 (can't do without pic features) and now I can't get this to work. It won't save the same way in SIM settings in 8.1 as it did in 10. Any ideas?

Edit:
Working. Must have http:// for the mms part.

But...I can't share my internet... Help?
 
Last edited:

Mike Newport

New member
Feb 5, 2015
172
0
0
Visit site
Just started fresh with my 1020. IS works now on 10586, but no MMS. Anyone run into this?

Same issue here if your on 8.1 and upgrade the mms is fine its when you hard reset after upgrade you have to go to access point and copy the unactivated access point settings and make a new access point and activate it and then mms will work properly, also if you upgrade font hard reset its won't let you update over 27 apps and it reverts you toCyan rather then Lumia windows 10 , which is what you get if you don't hard reset.
 

CJ Thunder

New member
Feb 16, 2011
714
0
0
Visit site
That was a little hard to understand...
but access point brings in settings from your SIM, right? Somehow I have T_Mobile settings, I made my own t-Mobile settings and my speeds are great and I don't get the access point error on bootup...So,how do I fix?
Go back to 8 and my IS doesn't work or stay on 10 and my mms doesn't work. Both are unacceptable.
 

Mike Newport

New member
Feb 5, 2015
172
0
0
Visit site
That was a little hard to understand...
but access point brings in settings from your SIM, right? Somehow I have T_Mobile settings, I made my own t-Mobile settings and my speeds are great and I don't get the access point error on bootup...So,how do I fix?
Go back to 8 and my IS doesn't work or stay on 10 and my mms doesn't work. Both are unacceptable.

I have a Nokia Lumia 1020 U.S. Att, and when your running windows mobile 8 or 8.1 if you go into access point settings, you can long press the Active T_Mobile and view the APN Settings, this is the APN settings that are automatic when you insert your tmobile sim card. When you long press it and view the internet APN settings it should say, fast.t-mobile.com, and then when you scroll down to MMS APN settings, your MMS Access Point Name should be fast.t-mobile.com, you then scroll down to your MMSC address and it should be http://mms.msg.eng.t-mobile.com/mms/wapenc those settings allow you to use both data as well as MMS messaging. When you go to windows mobile 10 insider preview you can select either fast or slow and then upgrade your device. After your upgrade it migrates your data and you dont lose any saved data including apps and all, if you go back into your APN settings you can look at T_Mobile and see wheter it is active or not , when it is not active its colored and when long pressed will come up with an error. On the Fast ring insider preview build 10586 once you upgrade it shiuld be good to go, but if not, you have the ability to press the +, this allows you to set your own APN Settings, Under Connection Name you put T-Mobile, then under access point name you put fast.t-mobile.com you then scroll down to MMS APN and the MMS Access point name should be fast.t-mobile.com ,then scroll down to MMSC address and it should be http://mms.msg.eng.t-mobile.com/mms/wapenc once you have completed those steps you then click the check mark and it will take you back and show both as inactive , you then long press your new APN called T-Mobile and activate it, this then allows you to send MMS as well as you data on windows mobile 10 or windows mobile 8 or 8.1 .
 

CJ Thunder

New member
Feb 16, 2011
714
0
0
Visit site
I've done all that before, but this time it didn't work. So...I don't know what to do. Guess I'll just carry my dev iPhone for IS until I buy a 950xl.
...still a pain, and not really understandable for why I am getting this error.
 

Felizelgato

New member
Aug 4, 2015
1
0
0
Visit site
Hi, thanks a lot for this info. I was having problems with my t-mobile lumia 640, signal kept dropping all the time and this fixed it, thanks, you saved me:smile:
 

Members online

Forum statistics

Threads
322,405
Messages
2,241,955
Members
427,920
Latest member
ohlawd