This App can't run on your PC

hangfirew8

New member
Jan 12, 2014
12
0
0
Visit site
Background: This is a desktop with a fresh of Windows 7 64 that was force-upgraded to Windows 10 64 by Microsoft, without my consent.

Just recently had a problem with Grey Screen of Death, so I replaced the video card. I had no ability to remove the driver first because of GSOD. Went from a GTX275 with latest drivers to an 8800GT (what I had lying around).

System booted right up and Graphics are running OK now. When I went to run the Nvidia drivers uninstall, I got "This App can't run on your PC". I downloaded the 8800 drivers (which appears to be the same d/l as the GTX275 drivers) and got the same error trying to run that. I tried to run the previous driver install d/l, which was only a few weeks old and worked fine then, got the same error.

PC passes overnight run of memtest86.

Since then I have tried the following:
Run all apps that fail as administrator. No change, same error.
Many reboots.
Turned off Smart Screen. No change.
Turned off Microsoft Defender. No change. (turns itself back on at reboot).
Turned UAC all the way down. This did nothing, but now I can no longer turn it down any more. It is now locked one notch below full.
Tried to create a new user with Admin privileges. This is the standard fix. Account creation failed with unhelpful error "Something went wrong"
Tried various paths of creating new user including with Microsoft account, all attempts end in Something went wrong.
Reset PC (reinstall Windows 10) results in error "There was a problem resetting your PC. No changes made"
Reboot to Option 7 ran check disk, 100%, booted up. No change, all the same apps still result in "This App can't run on your PC".
Tried to load registry hack for Take Ownership. Regedit fails to launch with "This App can't run on your PC".
There is no prior restore point. (There was under Windows 7)
There is no previous build to revert to.

I'm running out of ideas. I'm ready to save off user data, reinstall Windows 7 and be done with it, but maybe I'm missing something first? Or maybe I'll just move to Mint. Any problems there, I can solve myself.
 

Maurizio Troso

New member
Aug 22, 2014
4,692
0
0
Visit site
Try booting opressing repeatly CTRL for entering in start menu then chose Safe Mode
Your pc should boot in default VGA screen , so you can remove all your videocard drivers in device list

SO reboot, your pc should reboot in HD video software emulation mode, then it will try downloading latest WDHQ signed video card drivers available for your card, then give you a notice.

I'm betting it's a old pc, so avoid download official drivers, they are made for latest products. Use Windows doenloaded drivers
 

hangfirew8

New member
Jan 12, 2014
12
0
0
Visit site
Thank you! Good ol' Safe Mode fixed it. Ctrl was ignored, but msconfig got me there... after I stopped confusing Diagnostic mode with Safe Mode one tab over.

I started out with F8 but now I've learned that doesn't work any more. Then I went off into all those Google bunny trails listed above.

It is an old PC, but I did reload Nvidia drivers, because it is used for gaming. If I have problems with that, though, I'll take your advice and try the Windows built-in drivers.

Thanks again.
 

Members online

Forum statistics

Threads
323,730
Messages
2,244,292
Members
428,106
Latest member
prakik90