Thumbnails only partially display on internal data drive (G drive)


New member
Jul 14, 2020
Visit site
* Thumbnails only partially display on internal data drive (G drive). This does not affect thumbnails on OS drive (C drive), where OS was recently reinstalled. Thumbnails display properly on C drive.
* Both C and G drive are mounted internally in Windows 10 desktop. Problem is only on G drive, and only after reinstalling OS to C drive. G drive is a 10tb data drive. Both drives are NTFS. NOTHING has been changed about G drive location, connections, or mount point - same before and after reinstalling OS on C drive.
* I have tried Disk Cleanup tool, both from right-clicking drive, and running from taskbar search. Only C drive has option to clean out thumbnails, and this does not correct issue. G drive does not have that option, only options are DirectX Shader Cache, and Recycle Bin.
* I have tried running chkdsk on G drive, result is negative: no errors found.
* I want to try locating and deleting all thumbnails connected with files on G drive. I do not know the location of these thumbs, even if they are on the C or G drive. What is the location of G drive thumbnails, for manual deletion, or do you have any suggestion of how I can get system to delete them?
* I am an advanced user. I can use command prompt solutions using CMD if desired.


* The folder in the first screen shot above is on G drive. All of these files in the image are good and not corrupt. They open and display well in image viewer. They all used to show thumbnails as normal before reinstalling windows on C drive. Now some of them have no thumbnails, and I cannot find how to get system to create them as it should. Normal procedure would be to delete thumbnail cache, and system would create fresh ones. But I do not know how to do that on the G drive.



* You'll see if you compare the next 2 screen shots above, that the G drive DOES NOT have the option to delete thumbnails under Disk Cleanup options. In the last shot, you see the C drive DOES have the option to delete thumbnails under Disk Cleanup, but that does not help the issue.

* I then used a use a search tool to find and delete all files with string *thumbs* of type .db, this was almost 200 files. Unfortunately, this did not seem to resolve the problem. When I reopened the folder in my screen shot, it was clear these thumbs were not deleted. You can tell when they are, then you see the system quickly recreate them. This was not the case, and all the same files are still missing thumbs.

I'm desperate to get the thumbs back. I'm always handling these image files, and it's driving me crazy that I can't see at a glance which is which.

Thanks for any help.

Members online

Forum statistics

Latest member