Videos not showing in browser and sound problems

anon(9603734)

New member
Aug 15, 2015
149
0
0
Visit site
Hi all

I have a brand new Surface Pro 4 (m3, 4GB Ram, 128GB SSD), but am having an issue with it.

It came preinstalled with Windows 10 Pro 10586.2xx. Updated via Windows Update to latest cumulative patch 10586.5xx. Anniversary Update was not appearing via Windows Update. Before properly setting it up, I wanted to be fully up-to-date. I obtained the Window10Upgrade.exe file from the Microsoft website. It upgraded to 14393.51. I spent some time setting the device up and personalising, ensuring all Store apps were up to date, etc. Then I shut the device down.

When I next turned on the device (I always fully shut down when I have finished using) a notification / action centre message appeared along the lines of: "Audio not working? Click here to troubleshoot." Indeed there was no sound. From memory, troubleshooting did not identify or fix the issue.

Furthermore, when using the browser, videos would not show/load/play. A black square would show, as per screenshot:

NoVid.JPG

After a short(ish) time a message appears at the bottom of the screen "<website> is not responding". Closing the message does refresh the page, but again it loads with a black square where the video should play. (This time no further "not responding" message appears.)

You will notice on the right hand side there are further videos. Clicking on the link would load the webpage, but the black square would show.

All I get from YouTube is a dotted circle going round, as below:

YT.JPG

This issue does not only happen on Edge, but occurs on all browsers (Opera, IE11).

I can confirm that "use Adobe Flash Player" is on in settings.

I searched the internet and found a suggestion to, via the control panel, alter internet options to ensure "use software rendering instead of GPU rendering" was ticked, and that a further option under security was ticked. Following this change, restarting the device then seemed to fix the issue - video was now showing/playing in the browser as it should be.

However, the next time I switched the device on the "audio error" notification message came again and videos were not showing in the browser - it had returned to black squares.

I have tried checking for driver updates via device manager (under the sound video game controllers section), but the computer told me everything was up to date.

DM.JPG

After some further experimenting last night, I seemed to find that if I fully shut down the device then the next time I turn it on the "audio error" notification message appears (and I have no sound whatsoever) and videos would not show/play in the browser. However if I then restarted the device everything worked as it should.

My conclusion was that something must have not quite gone right during the installation, so this morning I set about installing afresh again. A slightly different method, from the media creation tool (although I did not put onto USB drive - I assume it downloaded the files to the hard drive and then automatically started installing).

A while later, it has installed Windows 10 again (14393.51 straight away I noticed). Despite having to troubleshoot a problem with the webcam everything worked fine - no problem with sound and websites loaded videos. Even after a full shut down and turning the device back on, everything was ok. I tested that a couple of times. However, this afternoon, the audio issue and also video not showing/playing in the browser have returned.

I have uninstalled the display audio and definition audio drivers, restarted the device, but that has not fixed the problem.

Has anybody had this problem and overcome it?

Does anybody have any suggestions?

When the device is working properly, it is brilliant. But this issue is driving me crazy!!!

I do not know if the device worked without issue under 10586.xxx, as I wanted the Anniversary Update installed before using.
 

Chintan Gohel

Active member
May 23, 2014
10,785
1
36
Visit site
I'm suspecting that you may have a faulty device rather than the software being the problem - would it be a hassle taking it back for checking or replacement?
 

anon(9603734)

New member
Aug 15, 2015
149
0
0
Visit site
I'm suspecting that you may have a faulty device rather than the software being the problem - would it be a hassle taking it back for checking or replacement?

I'd like to exhaust all options first but I bought it online from a reputable high street retailer, so it should not be a problem to return if it comes to it.

I'm almost definite now that when the device is turned on after being fully shut down, not everything seems to be loading "under the hood" on boot up. A restart of the device clears the issue - everything then works perfectly (so everything "under the hood" seems to have loaded following the restart).

Post 3 on the below thread seems to be having the exact same issue:
http://forums.windowscentral.com/microsoft-surface-pro-4/434248-au-issues-video-all-browsers.html

Post 1 also seems to be a similar issue, and he had no issue prior to the Anniversary Update.

I'm certainly no expert with computers, but it leads me to think there is possibly a software issue somewhere.
 

jdooms

New member
Nov 10, 2014
17
0
0
Visit site
I am having the exact same issue this morning. It was perfectly fine yesterday. Any help would be greatly appreciated.
 

Members online

Forum statistics

Threads
324,237
Messages
2,245,217
Members
428,179
Latest member
joshi