Why is my glance screen showing "battery saver" all the time and no weather?

Oct 21, 2013
10
0
0
Visit site
Hi all, I have a Lumia 920 Cyan with WP8.1 and the latest october update. I want to see the weather on the glance screen, however this is now showing up even after lots of trial and error. It may be that a related problem is that the battery on the glance screen always shows the shield as if it were on battery saver mode, the only time it changes is when I'm charging it (it shows the plug icon).

Can anyone help me solve this issue?
Thanks!
 

jfa1

New member
Dec 15, 2007
2,567
1
0
Visit site
Used to have a 920 now on the 1520. I never experienced that on either device. I am guessing that you have tried a soft reset and that did not help. If not try the soft reset. I fiddle around on the 5120 when I get a chance and see if I can figure anything out.
 

Microsoftjunkie

New member
Jun 19, 2012
1,624
0
0
Visit site
Turn off Glance, then re-install it.
To do that, change your date to year 2114 or anything past a hundred years I believe and tap on Glance from settings. It will give you a prompt to uninstall.
 

betterlife19

New member
Oct 28, 2014
17
0
0
Visit site
I had this issue on my lumia 920 several times after 8.1 update....its that the battery saver is permanently on and you can do nothing about it to fix it other than Hard reset....Since glance updated i had to hard reset my phone because it also conflicts with some live tiles and that touch capacitive keys do not light up.
Do a hard reset and do not worry about your apps and settings, go to backups and make a backup of apps and settings it will take 10 minutes. After you reset and login to your Microsoft account it will restore everything thing, from apps to start screen layout, but will take several hours depending on your apps and internet connection
it works fine now and its been a month since i did this

Edit: Just a reminder that it has nothing to do with glance, its solely a batter saver bug
 

LuvMeSomeWP

New member
Apr 4, 2014
65
0
0
Visit site
Actually, looks like uninstalling and reinstalling glance has caused more problems. Notifications no longer turns on the screen briefly to show the toast. Turning glance off returns the function back to normal... Really hoping hard reset fixes everything now!
 

furkanavshar

New member
Jun 7, 2014
66
0
0
Visit site
Hi guys, this is related to Device Hub. Yes, exactly!

So, -the only one- solution is:

1) Reset your phone (required)
2) When resetting is completed, complete your installation steps
3) When the phone is ready to use, quickly go to Settings > Date+Time
4) Set the year like 2150 or more
5) Go to Settings, tap the Device Hub
6) Uninstall it
7) Set the date as auto again

Problem is solved.

Never open Device Hub even once! Uninstall it and don't install again.

p.s. If you open Device Hub even once, battery saver crashes and your issue comes over again. Then you must reset your phone to solve it.
If you open Device Hub once, uninstalling it will not solve this issue. You will have to reset your phones...
 

Members online

Forum statistics

Threads
324,061
Messages
2,244,908
Members
428,160
Latest member
smellincoffee