Why isn't my SP3 booting?

  • Thread starter Windows Central Question
  • Start date

Windows Central Question

SP3 not booting

Hey guys, I have a huge problem with my Surface Pro 3.
Last week while I was downloading something the screen went black, since I was not actively using it I thought it just went into power saving mode so I tried to push the power button to wake it up, but I didn't geht any response. I played around with the power button a little and it booted up, but minutes later the same thing happened again and it wouldn't boot for about two hours. I finally got it to boot somehow, but after using it a little it shut off for a third time that day.
Yesterday it happened twice, but this time while I was using it. The screen went black and I couldn't get it to boot for an hour or so. Same thing just happened again a few minutes ago for the second time today. I tried to log in and it just shut down and isn't responding to anything. It seems like it is trying to boot though, when the type cover is attached it lights up for a second when I push the power button.

Now before you suggest it, of course I googled the problem and found a few possible solutions like the power-button-and-volume-up method on the Microsoft help page, but none of those work. The only thing to get it back to life is to repeatedly press and release the power button until it boots. But that offen takes 30 minutes or longer.

Software is up to date, and there is no junk installed. I got this device just 2 months ago from Microsoft because I dropped my old one.

I have the feeling it's a hardware problem and will probably have to send it back to Microsoft which sucks because I have finals in three weeks and need it.

I just wanted to know if anyone has similar problems and maybe even knows how to fix it if it is not a hardware but a software problem.

Thanks in advance and have a nice Sunday ;)


Aug 2, 2012
Visit site
Re: SP3 not booting

No offense but does it really matter whether anyone else has the same problem? I am sorry but that is the equivalent of breaking down on a highway and going online to a forum to see if anyone else has also broken down instead of doing the obvious. It is still under warranty so call Surface Support and get it replaced. Normal warranty replacement takes a week and expedited takes two or three days. They do not service the devices at all so you will get a replacement anyway, after they walk you through the various troubleshooting steps. BTW, since one of the steps they ask is to do a reset, I'd suggest you try it first. In this case though it does seem to be consistent with a component failure rather than a software issue....

Members online

Forum statistics

Latest member