Windows 10 Mobile Store Stuck on "Restoring user data"

PJL99

New member
Jun 28, 2016
118
0
0
Visit site
I am trying to re-install a Windows Store app (AccuWeather) after rebuilding my Windows 10 Mobile on a Lumia 950XL. The app appeared to download correctly in the Store installation queue, but the install appears to be stuck in the "Restoring user data" state. Does anyone have any advice for this problem? Thank you.
 

Maurizio Troso

New member
Aug 22, 2014
4,692
0
0
Visit site
I am trying to re-install a Windows Store app (AccuWeather) after rebuilding my Windows 10 Mobile on a Lumia 950XL. The app appeared to download correctly in the Store installation queue, but the install appears to be stuck in the "Restoring user data" state. Does anyone have any advice for this problem? Thank you.

Soft reset (hold power 15 secs) then retry installing
 

PJL99

New member
Jun 28, 2016
118
0
0
Visit site
Thanks, I had tried that but tried it again per your suggestion. The status is the same: When launching Store and going to the Downloads and Updates option the app still is in the download queue and shows "Restoring user data."
 

Charliefr3sh

New member
Mar 25, 2016
50
0
0
Visit site
Wait for it, it might take a (really, really) long time but it will finally install. I faced the same problem and I just let it sit after I had tried soft resetting, disconnecting from the internet......it ended just going through on its own
 

PJL99

New member
Jun 28, 2016
118
0
0
Visit site
Thanks. How long is a "really, really" long time so I can set my expectations?

If this were a desktop, I would run the Store troubleshooter and it would be fixed....sigh...
 

anon(8648115)

New member
Mar 5, 2014
181
0
0
Visit site
This has been a persisting issue on the anniversary update since the preview builds. One shouldn't have to wait several hours for an app to be installed, especially since the soft reset trick doesn't work anymore.
 

nnayr

New member
May 29, 2014
8
0
0
Visit site
this happened with me too. and not just the store, to all the MS apps that ship with the phone. i just waited and it seemed to resolve itself. of course i did try a few restarts but that had no effect.
now i didnt keep track of how long it took so sadly, i cant tell you.
 

TechFreak1

Moderator
May 15, 2013
4,620
15
38
Visit site
I have had that with several apps on my L930 and it took a few hours to clear it self up. So now I just update overnight with store set to only show notifications in the action centre.
 

Horvath Gyorgy1

New member
Jul 21, 2015
117
0
0
Visit site
Just to confirm, it also happened to me during the installation of Viber which showed a pending state in the apps list for about 2 hours and then 'miraculously' it finished installing itself.
 

miodrage

New member
Feb 16, 2013
318
0
0
Visit site
When something like this happens, feel free to do a soft reset (power and vol down till the phone vibrates). The installation should begin immediatelly after reboot and finish itself.
 

Members online

Forum statistics

Threads
324,228
Messages
2,245,194
Members
428,180
Latest member
TheStivo